Technical Fiat Abarth 500 issues

Currently reading:
Technical Fiat Abarth 500 issues

blackscell

New member
Joined
Sep 29, 2022
Messages
7
Location
Hoorn
Hi guys,

I bought a Fiat Abarth 500 from a friend of mine, he changed alot of parts but ended up selling it due to no time. I need some help to figure some things out. See attached pictures, my old and new (carbon) steering wheel. I have some problems with illumination. Alot of my buttons do not illuminate including the whole steering wheel/the convertible buttons/the mirror adjust buttons/the 3 buttons near the radio (sport/hazard/light), TTC and window defroster and the 2 buttons to regulate the windows. All of these do not illuminate, however they do work.

Anyone has an idea what it could be?

Also, he upgraded the tail lights to the newer models including the rear bumper with lights in it. Is there anyway to wire the rear bumper to light up when going into reverse? Because now nothing lights up when reversing.
 

Attachments

  • 1200_image-6.jpg
    1200_image-6.jpg
    80.8 KB · Views: 20
  • Carbon-Fiber-Abarth-Steering-Wheel.jpg
    Carbon-Fiber-Abarth-Steering-Wheel.jpg
    95.1 KB · Views: 10

A3jeroen

Well-known member
Joined
Sep 23, 2007
Messages
2,448
Location
Alkmaar, Netherlands
I think the pinout for the faceliftsteeringwheel is different. Hence no illumination. Do the buttons work Ok?
Are your rearlights with built in fog and reversing light? In order to not get the BCM (lamp warning) throwing a tantrum, you probably need relays and a live 12V to get the additional lights working.

gr J
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
7
Location
Hoorn
I think the pinout for the faceliftsteeringwheel is different. Hence no illumination. Do the buttons work Ok?
Are your rearlights with built in fog and reversing light? In order to not get the BCM (lamp warning) throwing a tantrum, you probably need relays and a live 12V to get the additional lights working.

gr J
Haven't checked yet as there is no radio inside. Any guide on the rekay stuff? Need to find that one out.

Any idea why the other buttons are not illuminating?

Also, I noticed my car does not go past 0.8 bar boost. He said he put a new turbo (180ps) on. Also, when downshifting from let's say 5th gear to 4th it has no boost pressure and stays there.

Scanning shows p0106-64, I'll start by replacing the manifold sensor
 

A3jeroen

Well-known member
Joined
Sep 23, 2007
Messages
2,448
Location
Alkmaar, Netherlands
You need to use the power for the fog and reversinglight to switch the relays and take the power from somewhere else. Otherwise you draw twice the power the BCM is expecting.
Your errorcode points to a boostproblem? Then it might not be a sensor.
My boostgauge never goes over 0.8 I think, but I tend not to watch it all the time.
Did he change the software after changing the turbo? Otherwise the ECU might not be able to control the turbo.

gr J
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
7
Location
Hoorn
Here is a video what I mean with the boost. When I downshift it seems like it is limited and does not go further.

Also a video of my buttons. Need to learn in the cluster.
 

Attachments

  • 20220930_231651.mp4
    28.8 MB
  • 20220930_232940.mp4
    37.5 MB
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
7
Location
Hoorn
Managed to fixed the lights, was a fuse. Tomorrow I am going to fix the tail lights to work.

Got a new map sensor coming in, then need to check what the car will do.
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
7
Location
Hoorn
Stumbled upon another weird issue. I wanted to fix the tail lights. I thought of splitting the reverse cable and routing it to the rear bumper lights. However, the rear bumper has a set of PDC going into the rear bumper lights. The car probably never came with PDC and without the lights in the rear bumper.

Any possible way to make this work? Purple plug is all the PDC + lights from my rear bumper. Yellow is the car's original plug behind the rear bumper, connected to nothing and no function
 

Attachments

  • 24552f80-b808-4ec9-b4fa-bfe5beb7a2fb.jpg
    24552f80-b808-4ec9-b4fa-bfe5beb7a2fb.jpg
    126.9 KB · Views: 7
  • d9fe1d13-2aa6-46e5-9ca2-c4b54230b7f9.jpg
    d9fe1d13-2aa6-46e5-9ca2-c4b54230b7f9.jpg
    90.3 KB · Views: 8
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
7
Location
Hoorn
Anyone? Do I need a PDA module? When going into reverse it shows a PDC error. So it does know it has PDC sensors. Just no clue how to get them working since this rear bumper was probably upgraded with pdc sensors attached
 
Top