Technical Fiat Abarth 500 issues

Currently reading:
Technical Fiat Abarth 500 issues

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Hi guys,

I bought a Fiat Abarth 500 from a friend of mine, he changed alot of parts but ended up selling it due to no time. I need some help to figure some things out. See attached pictures, my old and new (carbon) steering wheel. I have some problems with illumination. Alot of my buttons do not illuminate including the whole steering wheel/the convertible buttons/the mirror adjust buttons/the 3 buttons near the radio (sport/hazard/light), TTC and window defroster and the 2 buttons to regulate the windows. All of these do not illuminate, however they do work.

Anyone has an idea what it could be?

Also, he upgraded the tail lights to the newer models including the rear bumper with lights in it. Is there anyway to wire the rear bumper to light up when going into reverse? Because now nothing lights up when reversing.
 

Attachments

  • 1200_image-6.jpg
    1200_image-6.jpg
    80.8 KB · Views: 53
  • Carbon-Fiber-Abarth-Steering-Wheel.jpg
    Carbon-Fiber-Abarth-Steering-Wheel.jpg
    95.1 KB · Views: 22

A3jeroen

Well-known member
Joined
Sep 23, 2007
Messages
2,483
Location
Alkmaar, Netherlands
I think the pinout for the faceliftsteeringwheel is different. Hence no illumination. Do the buttons work Ok?
Are your rearlights with built in fog and reversing light? In order to not get the BCM (lamp warning) throwing a tantrum, you probably need relays and a live 12V to get the additional lights working.

gr J
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
I think the pinout for the faceliftsteeringwheel is different. Hence no illumination. Do the buttons work Ok?
Are your rearlights with built in fog and reversing light? In order to not get the BCM (lamp warning) throwing a tantrum, you probably need relays and a live 12V to get the additional lights working.

gr J
Haven't checked yet as there is no radio inside. Any guide on the rekay stuff? Need to find that one out.

Any idea why the other buttons are not illuminating?

Also, I noticed my car does not go past 0.8 bar boost. He said he put a new turbo (180ps) on. Also, when downshifting from let's say 5th gear to 4th it has no boost pressure and stays there.

Scanning shows p0106-64, I'll start by replacing the manifold sensor
 

A3jeroen

Well-known member
Joined
Sep 23, 2007
Messages
2,483
Location
Alkmaar, Netherlands
You need to use the power for the fog and reversinglight to switch the relays and take the power from somewhere else. Otherwise you draw twice the power the BCM is expecting.
Your errorcode points to a boostproblem? Then it might not be a sensor.
My boostgauge never goes over 0.8 I think, but I tend not to watch it all the time.
Did he change the software after changing the turbo? Otherwise the ECU might not be able to control the turbo.

gr J
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Here is a video what I mean with the boost. When I downshift it seems like it is limited and does not go further.

Also a video of my buttons. Need to learn in the cluster.
 

Attachments

  • 20220930_231651.mp4
    28.8 MB
  • 20220930_232940.mp4
    37.5 MB
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Managed to fixed the lights, was a fuse. Tomorrow I am going to fix the tail lights to work.

Got a new map sensor coming in, then need to check what the car will do.
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Stumbled upon another weird issue. I wanted to fix the tail lights. I thought of splitting the reverse cable and routing it to the rear bumper lights. However, the rear bumper has a set of PDC going into the rear bumper lights. The car probably never came with PDC and without the lights in the rear bumper.

Any possible way to make this work? Purple plug is all the PDC + lights from my rear bumper. Yellow is the car's original plug behind the rear bumper, connected to nothing and no function
 

Attachments

  • 24552f80-b808-4ec9-b4fa-bfe5beb7a2fb.jpg
    24552f80-b808-4ec9-b4fa-bfe5beb7a2fb.jpg
    126.9 KB · Views: 15
  • d9fe1d13-2aa6-46e5-9ca2-c4b54230b7f9.jpg
    d9fe1d13-2aa6-46e5-9ca2-c4b54230b7f9.jpg
    90.3 KB · Views: 15
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Anyone? Do I need a PDA module? When going into reverse it shows a PDC error. So it does know it has PDC sensors. Just no clue how to get them working since this rear bumper was probably upgraded with pdc sensors attached
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Found the right connector for the PDC, plugged right in. Still not working, immediatly shows an error upon starting the car.

Also seem to have an intermittent airbag light. Turns on while driving and off within 30 seconds. Anyone has a clue?

Map sensor fixed the boost problems. Upgraded to a Garrett turbo and car is running amazing now.
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
MES can probably tell which sensor and which airbag is at fault.

gr J
Hi Jeroen de topper,

I tried using MES. I am 100% sure it is either the cluster or steering wheel. I tried moving the seats and nothing happened. I moved my steering wheel up and down and boom airbag lights up.

I scanned with MES while the red airbag light was on continuously, unfortunately MES only showed my headlights giving an error (aftermarket lights). Nothing about the airbags or PDC not working.
 

Attachments

  • WhatsApp Image 2023-01-14 at 18.16.16.jpeg
    WhatsApp Image 2023-01-14 at 18.16.16.jpeg
    231 KB · Views: 6
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Did you access the right control unit with the right adaptercable?

gr J
Hi Jeroen,

I think I found the culprit today. Decided to open up everything. My Maxisys ms906 also couldn't read the airbag codes but did read a ton of other codes including the faulty PDC. Bought one from Amazon, coming tomorrow I hope, let's see if I can make the PDC work by replacing this PDC sensor.

I removed the airbag and by wiggling a cable a resistor fell of, this is probably the reason why my airbag error popped up everytime when moving the steering wheel. The last person did an awful job with electricity. I'm glad I got it for a good price and managed to fix a ton one by one.

Tomorrow I'm gonna install some ambient lights inside the door panels and dash, fix the window buttons (one button cut off by previous owner and the other one stuck together with ductape so shorting often). Installed an aftermarket radio because the seller upgraded the dashboard to the newer models but none of the radios fitted. Managed to make it work by using the canbus cable of the previous model radio.

Hope to fix the car by this weekend and then I'll finaly be able to enjoy it, if not I'll come back here :) About the MES cable, mine was probably a low budget on couldnt get in much modules, got a new good one coming in.
 

Attachments

  • WhatsApp Image 2023-01-16 at 04.05.36.jpeg
    WhatsApp Image 2023-01-16 at 04.05.36.jpeg
    241.6 KB · Views: 7
  • WhatsApp Image 2023-01-16 at 04.07.42.jpeg
    WhatsApp Image 2023-01-16 at 04.07.42.jpeg
    223.6 KB · Views: 6
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
This is the result of the ambient light. Unfortunately had to saw an opening in the doors because they couldn't fit in there. I'm happy how they came out, could be slightly better but will look into that another time.
 

Attachments

  • 39e8b20f-d046-4894-b7f8-74a8a17a4157.jpg
    39e8b20f-d046-4894-b7f8-74a8a17a4157.jpg
    1.6 MB · Views: 7
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
I still have an older paid version of MES on my old laptop and all adapters. So you could always come by in Alkmaar when you can't get your MES working.

gr J
Appreciate your offer Jeroen, we're not that far apart (Hoorn). I'll let you know, tomorrow my MES cable arrives. See what it does, if not I'll give you a pm. Today I found out my radiator fan is not working. Fuses all ok, no clue how long I'm driving with a non working radiator fan.

Will do some tests tomorrow and see what pops up. Hope it won't be much of a headache.
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
Also, forgot to mention that I changed the faulty parking sensor to a working one. Still immediatly shows 'Park assist unavailable' on starting the car. Any idea what this could be? Am I missing the PDC module? Because the wiring loom was there. I know for a fact that the car didn't have PDC sensors from factory.

Possible to turn it 'on'; with MES?
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
I still have an older paid version of MES on my old laptop and all adapters. So you could always come by in Alkmaar when you can't get your MES working.

gr J
Hi Jeroen. Finaly got MES to work today. Could you do me a favor and check your steering wheel airbag parameter for driver 1 and 2 so I can get the right resistor?
Also, for the PDC. My wiring loom has 4 PDC connectors, my rear bumper only has 3 PDC sensors. That's probably why my PDC keeps failing
 

Attachments

  • 9d31cdb0-dc62-4530-ada6-b28ae38cd602.jpg
    9d31cdb0-dc62-4530-ada6-b28ae38cd602.jpg
    131.7 KB · Views: 5
  • 10a9c5f7-2ef7-42e6-baf1-63073bf1fe44.jpg
    10a9c5f7-2ef7-42e6-baf1-63073bf1fe44.jpg
    305.5 KB · Views: 5

A3jeroen

Well-known member
Joined
Sep 23, 2007
Messages
2,483
Location
Alkmaar, Netherlands
I can check it (not today though), but I'm a bit confused. Your problem is the driver airbag (2nd stage), but the value you post in the next picture is of the passenger airbag (2nd stage 3 Ohm).

gr J

Edit: Even if (big if!) the PDC controller is there, it might expect a different sensor (FL vs pre FL).

gr J
 
OP
OP
blackscell

blackscell

New member
Joined
Sep 29, 2022
Messages
18
Location
Hoorn
I can check it (not today though), but I'm a bit confused. Your problem is the driver airbag (2nd stage), but the value you post in the next picture is of the passenger airbag (2nd stage 3 Ohm).

gr J

Edit: Even if (big if!) the PDC controller is there, it might expect a different sensor (FL vs pre FL).

gr J
Oh I see now. Hmm, that's weird. Because when the airbag lights up it shows both errors on my dash. Thought it was in the same connector the driver's airbag and passenger airbag. They both go away the same time too
 
Top