Technical Dashboard indicator arrow light.

Currently reading:
Technical Dashboard indicator arrow light.

blackbike

New member
Joined
Apr 12, 2014
Messages
13
Hello everyone.

I've run my 1.2 Active for 7 years with no problems.

But now the right hand turn arrow on the dashboard has stopped working. The right turn indicators on the outside of the car still work fine.

Can anyone tell me how to remove the dash and change the bulb?

Any other advice gratefully accepted.
 

koalar

Well-known member
Joined
Oct 24, 2016
Messages
5,615
Location
Cheshire
don't know how to answer this without sounding patronising

but how you go about repairing it depends on your skill level

unfortunately the instrument panel has surface mount L.E.Ds so isnt an easy repair for most people

you can change for a secondhand dash and do a poxi alignment

you need the correct software (not cheap) or know somebody that had and the replacement dash has to have lower miles than the one your replacing

I would just replace the L.E.D but then SMD soldering is what I use to do
 

Attachments

  • temp.png
    temp.png
    639.9 KB · Views: 12
OP
OP
B

blackbike

New member
Joined
Apr 12, 2014
Messages
13
Thanks for the reply. Beyond my soldering skills.

Anyone know if the light is required for the MOT?

If it is I'll probably just run a wire from the front indicator to power an LED sellotaped to the top of the dashboard.
 

DaveMcT

Well-known member
Joined
Sep 14, 2009
Messages
18,496
As far as I know, indicator warning lights are not needed for the MOT and in bright daylight they often get missed. You could fit a louder clicker so the noise of that powerhouse you have ;-) won't drown out the standard tick tick sound.
 
Last edited:

koalar

Well-known member
Joined
Oct 24, 2016
Messages
5,615
Location
Cheshire
Please note

A faulty rear light cluster connector. Very common, can and does cause the indicator on the dash either flash at twice the speed or not to indicate at all.


Check carefully as they can work but strangely you need to use an assistant, mirror or video camera


There has been a recent thread on here about the dash indicator not working.
 
OP
OP
B

blackbike

New member
Joined
Apr 12, 2014
Messages
13
Please note

A faulty rear light cluster connector. Very common, can and does cause the indicator on the dash either flash at twice the speed or not to indicate at all.


Check carefully as they can work but strangely you need to use an assistant, mirror or video camera


There has been a recent thread on here about the dash indicator not working.
I'll take the RH back light off and see if I can clean up the connector. Thanks for the tip. Worth a try.
 
Top