Technical Battery warning light intermittent

davehjones

New member
Joined
Nov 20, 2021
Messages
3
Hiya, new to the forum, I have a 2017 Classica, which doesn't get much use, Covid hasn't helped. Anyway I let the battery drain to much while it was sitting in the garage and needed to charge it before the car would start, thought that was that. The car went for its 3rd service, no problems, but when I got home and was putting it away the charge system warning came up, and on checking the battery voltage was low, around 12.3 v from memory,(this was June), I recarged the battery and gave it a short run, no problems. Move on a few months (Battery on a maintenance charger and starting it up every so often to stop the oil drain issue) and we took the car for another trip and after about 20 miles the charge warning has reappeared. After scouring google looking at MX5 sites as well most likely cause is battery (still showing about 12.3V) but other discussions say the charge rate rarely goes above 12.8v apparently, replaced the battery, but its still the same.. Voltage when running at a few thousand revs is still only 12.3 but the light only comes on after a few miles and when under load. any ideas? 2K miles, no fault codes....
 
OP
OP
D

davehjones

New member
Joined
Nov 20, 2021
Messages
3
The charging system is mostly Mazda I think, although the alternator is the same part number as the 500x..
 
Joined
Oct 22, 2017
Messages
3,821
Location
West Yorkshire
An alternator should be putting out at 13.8 to 14.8 vdc with and without load if I remember correctly.

Smart alternators often put s bit less out and then dump high voltage/current into the battery when off the throttle and slowing down but should definitely be way more then 12.3v
13v+ I'd have thought to at least maintain the things drawing power from the battery and put a small ammount back into it
 
Top