Technical 2013 Electrical Problem - Front Dash

Currently reading:
Technical 2013 Electrical Problem - Front Dash

stej96

New member
Joined
Mar 18, 2023
Messages
2
Points
1
Location
Liverpool
Hi,

Sorry if this has been covered in the past but I couldn't find a post that answered my problem.

I have a 2013 Punto and yesterday the front dash controls went down, everything except the symbol to say my headlights are on. I have tried disconnecting the battery for about 5mins and then starting it again and nothing, also tried a new fuse.

The only thing coming on with the console is the centred LED display comes on for a few seconds when starting and stopping the engine and the headlight light. I've not got any other lights or speedo, revs, fuel, temp etc.

Any ideas?

Thanks in advance.
 
Joined
Apr 27, 2011
Messages
32,006
Points
6,975
Location
Near the M4
Hi,

Sorry if this has been covered in the past but I couldn't find a post that answered my problem.

I have a 2013 Punto and yesterday the front dash controls went down, everything except the symbol to say my headlights are on.

The only thing coming on with the console is the centred LED display comes on for a few seconds when starting and stopping the engine and the headlight light. I've not got any other lights or speedo, revs, fuel, temp etc.

Any ideas?

Thanks in advance.

Hi

Generally pretty sound electrically :)


Assuming you know the car hasnt been thrown together from random parts in the last 6 weeks.. ;)


Most likely is fracture wiring at the hatchback hinge area..

I read similar recently on here..

2010 evo.. or 2012+



Do let us know how that wiring looks :)

( search 'maybelline' on here for basic fault info)
 
Top