Technical 2000 Brava 1.6 16V revs up to 3000 RPM in neutral

Currently reading:
Technical 2000 Brava 1.6 16V revs up to 3000 RPM in neutral

Joined
Feb 19, 2020
Messages
5
I've got a 2000 Brava 1.6 16v, runs on gasoline & LPG.
For a few years the car has been revving up to 3000 RPMs in neutral whenever I am at a red light. Once I put the car in gear and start moving, revving just stops.
I've taken the car to multiple different mechanics but no luck.
During these years we've tried changing many things, which include spark plugs, spark plug cables, fuses.
Moreover, throttle body was cleaned, and ECU codes were cleared as well.
There are no lights about the engine on the dashboard either.
However still no luck and I am not sure where else to take my car because all the solutions were just temporary so far. It just starts happening after a while.

I'd appreciate your help.
Cheers!
 
Last edited:

Neverth

Active member
Joined
Jan 18, 2012
Messages
656
Not sure about LPG kit, but the 1.6 has idle air control valve/actuator that could stick. If you take the intake boot out you should see the throttle body open a bit when you put ignition on.
Or there is air leak in one of the vacuum lines or manifold gasket which is more likely as there is too much air. Smoke machine to one of the vacuum lines to see leaks.
Or the charcoal canister valve is sticking open/leaking?
 
OP
OP
P
Joined
Feb 19, 2020
Messages
5
Not sure about LPG kit, but the 1.6 has idle air control valve/actuator that could stick. If you take the intake boot out you should see the throttle body open a bit when you put ignition on.
Or there is air leak in one of the vacuum lines or manifold gasket which is more likely as there is too much air. Smoke machine to one of the vacuum lines to see leaks.
Or the charcoal canister valve is sticking open/leaking?
Alright, I'll check/have checked all these as soon as I can and update here.
 

Kheydin

New member
Joined
Aug 9, 2022
Messages
8
Location
Johor Bahru
I've got a 2000 Brava 1.6 16v, runs on gasoline & LPG.
For a few years the car has been revving up to 3000 RPMs in neutral whenever I am at a red light. Once I put the car in gear and start moving, revving just stops.
I've taken the car to multiple different mechanics but no luck.
During these years we've tried changing many things, which include spark plugs, spark plug cables, fuses.
Moreover, throttle body was cleaned, and ECU codes were cleared as well.
There are no lights about the engine on the dashboard either.
However still no luck and I am not sure where else to take my car because all the solutions were just temporary so far. It just starts happening after a while.

I'd appreciate your help.
Cheers!
Check your Throttle position sensor (TPS) or TDC sensor it might be broken..must be either one or both of them.
 

puntodeltathema

Active member
Joined
May 19, 2006
Messages
244
Location
Tonbridge, Kent
Presume you've checked the throttle cable (where present) is nice and free and not binding at all.

You said you had error codes cleared - do you know what they were?
 

Kheydin

New member
Joined
Aug 9, 2022
Messages
8
Location
Johor Bahru
Presume you've checked the throttle cable (where present) is nice and free and not binding at all.

You said you had error codes cleared - do you know what they were?

Throttle cable is not the problem. TDC Sensor and Timing Sensor. If both look good, the main problem is your Stepper Motor Sensor. Your vehicle is an automatic transmission right?
 
Top