Technical 1.9 JTD A/C working intermittently

Currently reading:
Technical 1.9 JTD A/C working intermittently

Jtdbrian

New member
Joined
Feb 7, 2022
Messages
2
Location
Cape Town
Hi All, I have found many useful tips, knowledge and links through the forum, however I am now stumped.

I bought a JTD Stilo 2003/4 about 2 years ago aircon never worked, checked the obvious and had the gas refilled with no joy, basically had a quick look around and guessed it was the stator that was cooked and never bother further.
2 weeks ago with the A/C switched off by some miracle it started working! It worked for 2 weeks and then stopped for half a day, then worked again?

Any advice, anyone experienced this or by some strange bit of luck know what the fix is?

I have checked the resistor by the fan (while it has seen better days still works, tested resistance etc etc) power to the stator is there, changed the fan, horn and a/c relays, gas is good hasn't lost a drop.

Any advice would very appreciated!
 
OP
OP
Jtdbrian

Jtdbrian

New member
Joined
Feb 7, 2022
Messages
2
Location
Cape Town
Oh to be clear the a/c when it started working and still now, would work whether the switch in the car was on or off🤷‍♂️
 

Ralf S.

Well-known member
Joined
Dec 3, 2003
Messages
4,159
Location
The land that time forgot
As long as the sensor under the right headlamp detects pressure, the rest should work. Maybe the sensor/signal is a bit moody?

Mine worked for 3 days after I had it filled with gas.. but then it lost pressure (the condenser was shot to bits... not sure how the guy had the bare face to charge the beast up) and so it stopped working again.

I did notice that pre-charge the a/c light would illuminate and the fan would go to speed 1 (or half?) even if the fan knob was in the "Off" position.. but since it stopped working, the a/c light doesn't come on and there's no airflow. I guess the condenser might have been leakinging but re-charging it made it burst at the leak, which probably definitely atmo'd the gas pressure.


Ralf S.
 

astacheva

Member
Joined
Feb 7, 2017
Messages
47
Location
Santo Domingo
If it has enough pressure and still doesn't work (the clutch doesn't engage) could be the a/c pressure switch aka pressure sensor which is located also under the the right headlamp, if this one has problem you should be able to see an error code on the OBD scanner (using MultiEcuScan) or check the a/c relay on the engine fuse box.
 
Top