Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 27-01-2004   #1
Join Date: Jan 2004
Location: Truro, United Kingdom.
Posts: 2
Thanks: 0
Trader Rating: 0
Engine Fault!!

Hey all,

I have a 1.9 JTD Stilo and I keep getting an engine fault. The light comes on, it beeps at me and displays "Engine Fault" on the screen. I've taken it to my dealer who surprisingly said they couldn't find anything wrong with it and couldn't get it to reinact the fault when they took it out. They said that they had cleaned connecters and checked the fuse box and maybe that helped it. So after 5 days in the garage i got my car back, was fine for a couple of days but BAM! Engine Fault again. It always seems to happen when i'm in any gear and reaching 3 thousand revs. Read in manual that its some injection failure or turbo failure... which does sound right because at 3 thousand revs is where the turbo normally kicks in (or so i believe, i'm not exactly a mechanic lol). Anywayz just don't know what to do, i could take it back to dealer cos its still under warranty but if they didn't find anything last time its gonna be a waste of time and i really don't want to be without my car for another 5 days. Any help will be appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Borromir is offline Reply With Quote Quote 
Old 27-01-2004   #2
Join Date: Oct 2003
Location: Bangor Not Wales, Iraq.
Posts: 312
Thanks: 0
Trader Rating: 0
I haven't heard that one before.
I think the turbo on the diesel kicks in a lot lower down the revs than that, like 1500rpm or summit. I can hear mine working as I take off up the street not revving anymore than 2000.

Les Ross
Certified by a Professional.
03 Stilo 5d JTD80 Active
PSI Powerbox and go-faster turtle.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Lester Piglet is offline Reply With Quote Quote 
Old 27-01-2004   #3
Join Date: Jan 2004
Location: Truro, United Kingdom.
Posts: 2
Thanks: 0
Trader Rating: 0
I'll take your word for that seeing as I really don't know much about cars. Most of the other topics about engine faults on this forum, the engines seem to quit completely. Mine however doesn't, it happens whilst i'm driving, most of the time the light comes on, beeps and then goes out as soon as the three beeps are over. However once the light stayed on for like an hour or more and it seemed like the computer had cut the power to the engine down to the bare minimum, i could put my foot to the floor and only get a slow acceleration. Its very annoying.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Borromir is offline Reply With Quote Quote 
Old 27-01-2004   #4
Status: DEFCON Grumpy
 
custard's Avatar
Join Date: Nov 2003
Location: Edinburgh
Posts: 30,129
Thanks: 495
Trader Rating: 1
custard has donated!
United Kingdom 
you have got a fault the loss of power is your engine management putting the engine on 'get home mode'this is so you can still drive home but avoid to damage to the engine,as lester piglet says on a diesel the turbo kicks in much lower than on a petrol engine due to the torquier nature of a diesel.take it back you paid the cash and if the get home mode is kicking in then there is a problem[:(!]

The Fiat Cinquecento
Fun While It Runs
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

custard is offline Reply With Quote Quote 
Old 28-01-2004   #5
Join Date: Dec 2003
Location: Skopje, Fyro Macedonia.
Posts: 437
Thanks: 0
Trader Rating: 0
Borromir does your revs scroll "swims" when you are in Neutral, standing on a traffic light or something like that. Does it stands firmly in one place or it slightly goes up and down for about 100-200revs.??

FIAT STILO 1.6 3dR Tiziano Red
Sub=Pioneer TS WX20LPA
AUTOMOBILE SK
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

janevj is offline Reply With Quote Quote 
Old 13-01-2008   #6
Join Date: Jan 2008
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Engine Fault!!

ive got a fiat stilo 53 plate i have the same problem as you, and a friend has a 52 plate which has also had the same problem, she took car back to garage they said it was bad fuel(bull). we are going to try some good fuel cleaner,our car seems to do it more in wet weather. this is the first fiat ive owned and think it will be the last.if you get your fiat sorted put what you have had done on the forum for me please.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

FAZ2946 is offline Reply With Quote Quote 
Old 13-01-2008   #7
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,531
Thanks: 679
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: Engine Fault!!

Hi mate,

I take it its a JTD like the OP

Have you moved you boost pressure solenoid? Its very common to get those symptoms when it gets wet because its located too far down in the engine bay. Most people move it to the side of the battery tray.

Hope that helps,
Alan
__________________
If you see a problem post, please click the report button

Last edited by a1ant; 13-01-2008 at 22:06.
a1ant is offline Reply With Quote Quote 
Old 14-01-2008   #8
popping out
Join Date: Sep 2005
Posts: 2,545
Thanks: 24
Trader Rating: 0
dan-the-man has donated!
United Kingdom 
Re: Engine Fault!!

what he said, happened to my old JTD, overboost valve located near the intercooler from where I can remember, take it out and dry it then relocate it to the battery tray, some FIAT dealers know about the relocation and some don't.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dan-the-man is offline Reply With Quote Quote 
Old 15-01-2008   #9
Join Date: Jan 2008
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Engine Fault!!

janevj,

Your reply to Borromir caught my attention. I'm experiencing the same problems as Borromir and have in fact returned the car to the dealership FOUR times in the last few months. Each time they tell me they can't find any problems, they clean this, reset that, I get the car back and the same thing happens.

Now, in addition to the warning signals, the revs gauge is restless when the car is stationary. Any idea?

thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jan Wouter is offline Reply With Quote Quote 
Old 15-01-2008   #10
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,531
Thanks: 679
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: Engine Fault!!

Hi mate, Welcome to the forum!

What car/engine have you got?

Alan
__________________
If you see a problem post, please click the report button
a1ant is offline Reply With Quote Quote 
Old 15-01-2008   #11
Join Date: Jan 2008
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Engine Fault!!

Thanks Alan. Its a 3 door Stilo, 1.6l engine. Best design/price deal in the world, but this 'engine fault' thing is cooling down the initial enthusiasm ;-(
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jan Wouter is offline Reply With Quote Quote 
Old 15-01-2008   #12
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,531
Thanks: 679
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: Engine Fault!!

Right ok, you can forget the thing about the "over boost valve" as that wont apply to your car.

How is the car idling when you first start it up from cold, in the first say 10 seconds. Does it idle nice and calmly, or is it still hunting up and down the revs?

Alan
__________________
If you see a problem post, please click the report button
a1ant is offline Reply With Quote Quote 
Old 15-01-2008   #13
Join Date: Jan 2008
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Engine Fault!!

The car starts smoothly Alan.

Jan
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jan Wouter is offline Reply With Quote Quote 
Old 15-01-2008   #14
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,531
Thanks: 679
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: Engine Fault!!

So its only after the first say minute that the needle on the RPM gauge starts moving up and down on its own?

If that's the case, then it sounds like its possibly a lambda sensor issue. However, i would have thought that Fiat would have looked at that when its been in to them about it. Do you know if they put it on the diagnostics machine at all?

Also have you noticed any change in your fuel consumption?

Alan
__________________
If you see a problem post, please click the report button
a1ant is offline Reply With Quote Quote 
Old 15-01-2008   #15
Join Date: Jan 2008
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Engine Fault!!

they have run the diagnostics tool on the car. They claim to have even called the Fiat concern. I'm returning the car again tomorrow and I'll mention the lambda sensor 'thing' though its latin to me. What is it?

I haven't kept track of fuel consumption (no board computer) but it doesn't seem abnormal. I'll keep an eye on it.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jan Wouter is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Uno Engine Swaps Chas Uno Uno 53 30-08-2017 20:57
(T) Problem.....RED Engine LED always on..... :( tubi Punto (Mk2/2b) 7 28-02-2006 12:48
(T) Engine Fault SHC Stilo 2 16-07-2004 16:37
(T) Engine Fault? msmbus Stilo 3 29-02-2004 22:01
(T) ENGINE FAULT! HELP? janevj Stilo 5 16-01-2004 05:18