Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 27-12-2005   #1
Join Date: Dec 2005
Posts: 7
Thanks: 0
Trader Rating: 0
Croatia 
Unhappy Security Failure/Engine Fault

Hi guys, merry christmas to those who celebrate it. Technically I'm not new to this forum because I've been reading it since 2002. when I could just think about buying a new Stilo.

However, I bought this car in 2004. (brand-new) and I was pretty happy with it till now.

What happened is that one morning (over month ago) when I was going to work, my Stilo reported "Security failure - loose connection" and I had to turn the key back (several times) to try to convince it to start. When I finally succeded in starting the car, after just a mile or so, it reported "Engine fault" and started to stall/stop. I think that was due to the fact that the "Security fault" during driving would cause the fuel pump (and some other devices) to shut, and finally the car to stall and stop. The car doesn't manage to display the first error message (Security...) because right after that the engine stalls and the ECU displays "Engine fault" even though there's nothing wrong with it. That kind of scenario happens all the time.

Now the solution... my dealer tried to replace the battery as the old one didn't have the green dot in the middle. Faults appeared anyways. Then they put my original battery as that was not the solution and tried to improve the connection on the connectors. That didn't work also (or they didn't manage to fix the loose connection - it's probably very difficult to trace and fix that sort of fault). Then they said that it was the body computer, and I had to wait for 3 weeks for it to arrive from the FIAT country. When it finally came, and after they changed it, no improvement was made - the same faults kept appearing, but I think that the situation even became worse. Now they do not know what to do with it other than to take some parts from the other (but the same) Stilo and put that into mine. That would take god knows how much time and probably wouldn't make much difference.

Is there any update for the body computer or whatever (I think that the new body computer should have the latest version), or an update for the injection computer or something. In october of 2004. I had to change the heater unit, then in november of 2004. i had the update for the injection computer. However, my dealer couldn't do that till february or march of 2005. Since then I didn't have any other updates. Where can I find an info on available updates?

Any help is welcome (I just saw the ePER catalogue and it looks that it can be of a great help). Maybe my problem has to do something with that low winter temperatures, so is there anyone that has the same problem in the morning (maybe on the same engine)? Where can I find some tech stuff like schematics etc (e-Learn?)?

Sorry for the long-ish post. Thanks in advance.
__________________
=2004. Fiat Stilo 1.9 16v 140bhp MultiJeT Dynamic=
zstef is offline Reply With Quote Quote 
Old 27-12-2005   #2
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Security Failure/Engine Fault

It's not a battery fault it's a connector fault,do you celebrate christmas,what connectors did they look at/test as the clue is monitoring 'Examiner',does the security(car & padlock)warning light stay on or flash?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T14086 is offline Reply With Quote Quote 
Old 27-12-2005   #3
Join Date: Dec 2005
Posts: 7
Thanks: 0
Trader Rating: 0
Croatia 
Re: Security Failure/Engine Fault

Damn those Bosch connectors then! When there's stangely nothing wrong with Fiat itself, then it's a Bosch fault.

When I turn the key, after just a second or two there's a beep and a message "Car Security Failure - loose connection". The car security warning light stays on along with the heater light and the fuel pump (water present) light. Normally when you turn the key, all sort of noises start to spread (airbag pumping etc.), but when this error comes up, nothing starts. When I finally get over the Car Security failure, I can turn the engine on, but if I don't, then I can see the engine light is intermitently turning off and on and the clicking noises appear from the front left /on the left hand drive/ (it's supposed to stay on untill the car starts). That is the fault.

When I turn the engine on, it tends to power off (intermitently).

The fault seems to disappear in time (with engine running, if it doesn't stop).

The examiner stated that some of the injectors are faulty, and that the body computer is faulty. None of those is probably true. Don't know which connectors were they trying to fix but I suppose that by fixing they mean spraying with the old WD-40. How can you check which of the connectors is faulty, and how can you repair it?
__________________
=2004. Fiat Stilo 1.9 16v 140bhp MultiJeT Dynamic=
zstef is offline Reply With Quote Quote 
Old 27-12-2005   #4
Super LOL!
 
Stu DemonD's Avatar
Join Date: Sep 2003
Posts: 23,471
Thanks: 426
Trader Rating: 1
Stu DemonD will never be forgotten
Stu DemonD has donated!
Jigsaw: Chess Pieces Champion
United Kingdom 
Re: Security Failure/Engine Fault

Quote Originally Posted by zstef
Where can I find some tech stuff like schematics etc (e-Learn?)?
You have PM
__________________
See you next Tuesday
Stu DemonD is offline Reply With Quote Quote 
Old 27-12-2005   #5
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Security Failure/Engine Fault

zstef....Damn those Bosch connectors then! When there's stangely nothing wrong with Fiat itself, then it's a Bosch fault.

Yep,although a respected name they have a few things to answer for

Look for connector D4(big connector under the engine compartment)your fault will no doubt be there
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T14086 is offline Reply With Quote Quote 
Old 27-12-2005   #6
Join Date: Dec 2005
Posts: 7
Thanks: 0
Trader Rating: 0
Croatia 
Re: Security Failure/Engine Fault

I'll check that out. Thank you all.
__________________
=2004. Fiat Stilo 1.9 16v 140bhp MultiJeT Dynamic=
zstef is offline Reply With Quote Quote 
Old 01-02-2009   #7
Join Date: Feb 2009
Posts: 18
Thanks: 1
Trader Rating: 0
llalakis has donated!
Greece 
Re: Security Failure/Engine Fault

Quote Originally Posted by zstef View Post
I'll check that out. Thank you all.
Hello,
Please can you tell me if this solve the problem?
I met the same issue and it makes me crazy!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

llalakis is offline Reply With Quote Quote 
Old 01-02-2009   #8
Join Date: Dec 2005
Posts: 7
Thanks: 0
Trader Rating: 0
Croatia 
Re: Security Failure/Engine Fault

Quote Originally Posted by llalakis View Post
Hello,
Please can you tell me if this solve the problem?
I met the same issue and it makes me crazy!!!
It didn't. I had to change the engine (injection) computer (not the body computer, the other one). No issues experienced since then.
__________________
=2004. Fiat Stilo 1.9 16v 140bhp MultiJeT Dynamic=
zstef is offline Reply With Quote Quote 
Old 01-02-2009   #9
Join Date: Feb 2009
Posts: 18
Thanks: 1
Trader Rating: 0
llalakis has donated!
Greece 
Re: Security Failure/Engine Fault

Quote Originally Posted by zstef View Post
It didn't. I had to change the engine (injection) computer (not the body computer, the other one). No issues experienced since then.
Thanks pal.
What was the cost?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

llalakis is offline Reply With Quote Quote 
Old 01-02-2009   #10
Join Date: Dec 2005
Posts: 7
Thanks: 0
Trader Rating: 0
Croatia 
Re: Security Failure/Engine Fault

Don't really know. It was replaced under warranty.
__________________
=2004. Fiat Stilo 1.9 16v 140bhp MultiJeT Dynamic=
zstef is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Brake Fault nbuchana Multipla 4 18-02-2009 19:21
(T) Engine Fault!! Borromir Stilo 15 16-01-2008 00:16
Does anybody work in security? The Negotiator Leisure Lounge 94 28-01-2007 17:53
Window Security Code lanchester01 Security 4 28-09-2005 09:25
(T) ECU fault / coil braden Stilo 5 29-03-2005 14:14