Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 22-12-2018   #1
Join Date: Sep 2018
Posts: 4
Thanks: 0
Trader Rating: 0
New Zealand 
loose connection message

hi all,

I have an 06 manual Stilo Abarth, recently and intermittently I get a loose connection message and sometimes a few warning lights then they go out immediately. This happens when aggressive accellerating typically uphill or aggressive corning (sometimes)

Other than that car runs great no issues with starting or cutting out. Any help or ideas greatly appreciated.

Cheers

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ajtkiwi is offline Reply With Quote Quote 
Old 22-12-2018   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 19,007
Thanks: 676
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by ajtkiwi View Post
hi all,

I have an 06 manual Stilo Abarth, recently and intermittently I get a loose connection message and sometimes a few warning lights then they go out immediately. This happens when aggressive accellerating typically uphill or aggressive corning (sometimes)

Other than that car runs great no issues with starting or cutting out. Any help or ideas greatly appreciated.

Cheers

James
Hi James. Probably most helpful to get the fault codes read.. it may point toward the item in Question.

No other weird electrics ??
Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 22-12-2018   #3
Join Date: Sep 2018
Posts: 4
Thanks: 0
Trader Rating: 0
New Zealand 
Re: loose connection message

Thx Charlie, do I need an OBD reader for codes? No other electrical issues I can see, just the message followed by random warning lights and messages like asr, ice warning and a few others. It all goes out almost immediately.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ajtkiwi is offline Reply With Quote Quote 
Old 22-12-2018   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 19,007
Thanks: 676
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: loose connection message

You need SOMETHING to plug into the OBD port.

OBD is a worlwide standard.. so will do basic ENGINE codes onost vehicles..

Your isdue sounds like a basic electrical connection.

SEARCH.. the stilo section for ASR FAULT. Etc. Bound to have been covered on here before..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 01-01-2019   #5
Join Date: Mar 2012
Location: Oamaru
Posts: 528
Thanks: 39
Trader Rating: 0
Maigretnz has donated!
New Zealand 
Re: loose connection message

Loose connection is often just what it says.
Check battery clamps and earth straps.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Maigretnz is offline Reply With Quote Quote 
Old 12-01-2019   #6
Join Date: Sep 2018
Posts: 4
Thanks: 0
Trader Rating: 0
New Zealand 
Re: loose connection message

Hi all,

This has still got me beat!

It only happens when either aggressive cornering or going over a big bump. the engine never shuts off always starts and runs great. The dash lights up like a christmas tree (pic attached while running) and dials drop aircon stops and radio, then fairly quickly goes away. Occasionally the ASR and DSP failure messages can remain but normally go out soon after.

here's what I've checked so far...
Grey fuse box and all connectors
Battery terminals and connections and also charge (good condition)
Checked ECU plugs all prongs in good order none sunken etc...
Basic OBD check never has any codes showing?
Attached Thumbnails
Click image for larger version

Name:	IMG_5949.JPG
Views:	12
Size:	667.3 KB
ID:	196601  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ajtkiwi is offline Reply With Quote Quote 
Old 16-01-2019   #7
Join Date: Oct 2012
Location: Turkey
Posts: 36
Thanks: 0
Trader Rating: 0
Turkey 
Re: loose connection message

I have solved it on my stilo.
Disassemble alllll parts of the battery connections, rub them with sandpaper.

Especially the + connection, loosen all bolts, I mean all of them and take photos, you will see what mean .
Elaborate on the 3 bolts under the red cap there
Likes wody21 liked this post
__________________
Peace at HOME! Peace in the WORLD

M . K . ATATURK
frostbite is offline Reply With Quote Quote 
Old 20-01-2019   #8
Join Date: Oct 2016
Location: Italy
Posts: 10
Thanks: 1
Trader Rating: 0
Italy 
Re: loose connection message

Had this problem on a 1.6
Check all the connection in the battery\fuse box, it worked for me
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jjjjack is offline Reply With Quote Quote 
Old 24-01-2019   #9
Join Date: Sep 2018
Posts: 4
Thanks: 0
Trader Rating: 0
New Zealand 
Re: loose connection message

Update - problem is fixed.

It was either a very slightly loose 8m earth bolt on battery strap or the ABS harness.

What I have found is its very tight between the abs plug and the Fuse box with the D4 connectors. What happens is when you lift the fuse box its easy to inadvertently pull the abs plug out slightly and when going over bumps or hard cornering - loose connection + abs messages etc...
Likes Yorkshire007, Davren liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ajtkiwi is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Loose Connection error message on a Fiat Stilo 1.2 Project 192 Tech Talk 3 29-05-2017 14:02
(T) Loose Connection Error Message Followed By Water in Fuel Filter Billy123 Stilo 1 09-01-2013 11:43
(T) error message "loose connection" smurf01 Stilo 22 05-05-2012 21:11
(T) JTD - Diagnostic message;Loose connection. pikeybob Stilo 1 09-04-2011 18:16
(T) 1.6 loose connection message [rpm sensor] D-Stilo Stilo 35 01-06-2007 14:31