Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 16-10-2013   #1
Join Date: Aug 2009
Location: Sunbury on Thames
Posts: 31
Thanks: 4
Trader Rating: 0
United Kingdom 
LIMP mODE pLUS

Stilo 1.9JTD 04 115.
Went into limp mode, disconnected Maf. Improved performance.

Bought Piersburg Maf together with new filters for oil, air, fuel, pollen. Did major service including EGR, actuator moving freely.
When all done and tested fitted Maf sensor, still in limp mode.

Gendan tester showed faulty Maf. Reset all OK. Maf error returned. thought problem due to Piersburg needing different voltage so got another from a scrap dealer, still same, it is possible that 2 give similar error - Just!!. Got a cheapo from ebay, reset faults fitted new Maf.

Still have limp mode, performance improves when Maf disconnected.

Back to the Gendan with a close look have 3 errors, Maf / Fuel temperature / Cooling Fan codes PO180 / PO480 / PO101.
With Maf disconnected have a different Maf code ONLY. Do not have the other two.

Obviosly a different problem with a common cause related to the Fuel Temp and Cooling Fan which are not diagnosed when Maf disconnected. Can find no common connection using the fuse tables in the Stilo Doc. Does anyone know of a source of the information on what is connected to what (Circuit diagrm) or better the actual info that may lead me to identify and fix.

Jus as an incentive I have guides in preparation for replacing the boot switch using an inexpensive switch and repairing a back caliper. But am using my spare time trying to resolve my Maf problem

Thanks for any assistance provided
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

multihull is offline Reply With Quote Quote 
Old 22-10-2013   #2
Join Date: Aug 2009
Location: Sunbury on Thames
Posts: 31
Thanks: 4
Trader Rating: 0
United Kingdom 
Re: LIMP mODE pLUS

Thankfully this is now resolved.

I was using old software to scan codes. This has been quite good in assisting me in keeping it out of the garage. But this time it gave me unconnectable errors.
I downloaded the MultiEcuscan software and with the Gendan ELM327 box ran the check again. This showed the Error - Inlet Air Temperature. This is a MAF failing to read the correct air inlet temperature, I was showing -34 degC and it was not that cold. So it looked like 3 faulty Mafs, got another new one today, fitted it and cleared fault. Engine now starts with no fault light. Great

I can understand the troubles people get into trying to sort out this type of fault. My old software was showing 2 temperature faults so it could not interpret the coding correctly. Probably there are several layers of rporting and the Maf air temp is on a lower scale.

My advice now can only be get the tols to do the job, and this error chasing on scant knowledge can only lead to frustration. I enquired at my local Fiat garage for a error check test and I was quoted 140 to do this and extra to correct the faults. The full test components were 84, I had the ELM327, and I am now able to do all of the ABS and all other sorts so 2 things: far less time to diagnose and more accurate component identification. Add saving garage fees in a lot of instances and i become a winner all round.

Will now have time to do the rear calliper repair guide and boot switch replacement with inexpensive switch.
Thanks alexGS thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

multihull is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Keep going into limp mode, HELP NEEDED!! EAG1 Grande Punto 3 24-01-2013 12:44
(Tu) Help Limp Mode lbhgaz Grande Punto 7 13-03-2012 20:25
(G) Stilo in Limp Mode pachamama Stilo 10 29-11-2011 15:43
Boxer in limp mode slick50 Non-FIAT 1 10-11-2011 19:58
(T) Limp mode again wegi Bravo 8 08-08-2011 08:14