Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 01-08-2011   #1
Join Date: May 2011
Location: Plymouth
Posts: 41
Thanks: 0
Trader Rating: 0
United Kingdom 
Angry Boot light not working

My boot light is driving me mad. It will not operate when opening and closing the boot. I have done the basics like test the bulb to actually make sure that's not the problem, during searches I found other people have had the same or similar issues and one guy hooked it up to the earth of the cigarette lighter, I have also tried this and by magic it works, however it won't turn off when the boot is shut and when the boot is shut and the car locked the indicators flash to say there is a door open and the boot will then not open on central locking when the car is unlocked.
So in many ways I'm no further on than I thought I'd be so am now asking for help to get this working once and for all because it does light up, proving there is power getting to it!

Thanks in advance
Jon
__________________
Jon
03 1.6 16v Stilo Active Multiwagon
phantomactive is offline Reply With Quote Quote 
Old 02-08-2011   #2
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Boot light not working

In order to fix it then you need to understand how it works.

Click image for larger version

Name:	boot lock 2.jpg
Views:	594
Size:	121.2 KB
ID:	93260
The boot latch has 2 sister switches in it, both of them tell the body computer the boot is open but only one is for the boot light, (the other is for the boot open warning) this tells the BC to "turn the boot light on" which it does, through a current direction diode to the bulb which then earths through the same boot light switch

The fact the boot light works when you manually earth it means
BC is turning it on
Diode is ok
Bulb is ok
Bulb contacts are ok
What isn't happening is one of the boot latch switches telling the BC that the boot is open by supplying an earth to the BC
The fact the boot light stays on for ever when you manually put an earth on the bulb contacts confirms the earth is not being supplied by the boot latch. Do you get a "door open" warning when you open the boot? If so then the boot latch is connected to earth ok if not then it's the boot latch earth line at fault (or a previous owner got fed up with it and disconnected the connector there)

If you get the normal "door open" when you open the boot then put a bridge wire across the two sister switches contact wires and see if it all works ok then. You could join the two sister switches wires permanently as the other switch is working otherwise you would get "boot open" warnings or you could put your own magnetic sensing switch there or you could add some glue to top of switch contact lever to make it reach far enough to work or renew the catch (or you could just use a torch)
Thanks dave thanked for this post
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 02-08-2011 at 09:38.
Deckchair5 is offline Reply With Quote Quote 
Old 02-08-2011   #3
Join Date: May 2011
Location: Plymouth
Posts: 41
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Boot light not working

When the boot is open I get a message to say boot open. I have looked at my lock as per your picture and one wire is a little loose so will remove and solder back again, is there a way to get at the 2 micro switches? I guess another option would be splice into the White cable of the light and fit a switch to an earth and manually turn the light on and off when needed.

I will remove the lock and try and get to the switches to bridge them and report back.
__________________
Jon
03 1.6 16v Stilo Active Multiwagon
phantomactive is offline Reply With Quote Quote 
Old 02-08-2011   #4
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Boot light not working

When the boot is open I get a message to say boot open.
OK so that means the boot lock is connected and has an earth

I have looked at my lock as per your picture and one wire is a little loose so will remove and solder back again, is there a way to get at the 2 micro switches?
Yes take the lock out or you can simply bridge the sensor wires in situ

I guess another option would be splice into the White cable of the light and fit a switch to an earth and manually turn the light on and off when needed.
Yes that'll do it
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX
Deckchair5 is offline Reply With Quote Quote 
Old 02-08-2011   #5
Join Date: May 2011
Location: Plymouth
Posts: 41
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Boot light not working

Have tried to locate the rear fuse box and I don't have one! See attached pics, I was looking for it so I can check the earth on C30 I believe is the correct one.
I have the multi wagon and looked on here and in the user manual. So I'm a little stumped now :s

http://db.tt/ukapRWM
http://db.tt/LpIlBGb
http://db.tt/6vLxe5V
__________________
Jon
03 1.6 16v Stilo Active Multiwagon
phantomactive is offline Reply With Quote Quote 
Old 02-08-2011   #6
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Boot light not working

Why are you doing that? You know C30 is working as your boot open warning uses the same earth from the boot latch switch. If you need to check it then just set your multimeter to resistance, one end on pin 2 black/purple wire of the boot latch and the other on any shiny metal earth in the boot area, near zero resistance? ok earth to C30 is good

Whilst you're there see if pin 3 white wire goes to earth with boot open. No? There's you're problem.

See if boot open warning pin 1 goes to earth with boot open. Yes? Connect the white wire to that one

Come on! The owner wants his car returned by tonight
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 02-08-2011 at 15:06.
Deckchair5 is offline Reply With Quote Quote 
Old 02-08-2011   #7
Join Date: May 2011
Location: Plymouth
Posts: 41
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Boot light not working

Got it fixed. Took some fiddling but job done. Technically I'm not sure what I did but basically involved snipping a wire and putting it somewhere else. See pics.
http://db.tt/vPynqGR
http://db.tt/oVPuZLY
http://db.tt/8aStxSM

Whatever I did it worked.
__________________
Jon
03 1.6 16v Stilo Active Multiwagon
phantomactive is offline Reply With Quote Quote 
Old 02-08-2011   #8
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Boot light not working

That's the stuff!
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX
Deckchair5 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Boot light not working!!!! markoisuk Grande Punto 4 31-01-2011 14:32
(T) Boot Light Working Sporadically whenisayjump Grande Punto 5 29-12-2010 15:50
(G) Punto 55S internal reading light & boot light not working - fuse? dvdfever Punto (Mk1) 7 20-02-2007 02:08
(G) Boot light not working 12ichard Stilo 2 19-11-2006 20:39
(T) Boot Light not working... wotnowarninglight Stilo 7 21-03-2006 14:12