Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 08-02-2011   #1
Join Date: Feb 2011
Posts: 12
Thanks: 0
Trader Rating: 0
Ireland 
fiat stilo 1.6 16v ele fault

i am new to this... got into my stilo the other morning and the battery was dead (nothing left on the the car and battery is okay) then i jump started it and driving up the road the horn went off while driving i took the fuse out and horn still going off (It was the right fuse) the ele roof was going back and foward and the fan was staying on i had to disconnet the horn for it to stop.. Then went to the shop and came back and the battery was dead within half an hour.. Fan still on when the car is off even when the fan stops battery still going dead with nothing on..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

murphy2010 is offline Reply With Quote Quote 
Old 08-02-2011   #2
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: fiat stilo 1.6 16v ele fault

Sounds like you have a short circuit problem with the under bonnet fuse and relay panel B1. Been spraying some water around in there?
Click image for larger version

Name:	horn circuit relay T3.JPG
Views:	38
Size:	27.6 KB
ID:	86658
If you pull out relay T3 that will stop the horn


Relays T6 and T are the rad fan relays -don't pull those out permanently - but they're also on B1 panel so I'd look there for your problems

Has anyone installed a new head unit? Wrong wiring there will cause battery drain
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 08-02-2011 at 21:58.
Deckchair5 is offline Reply With Quote Quote 
Old 11-02-2011   #3
Join Date: Feb 2011
Posts: 12
Thanks: 0
Trader Rating: 0
Ireland 
Re: fiat stilo 1.6 16v ele fault

Thanks very much i had taken the cover of a few days before and driving home from shopping water must have got in cause there was a few floods on the road..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

murphy2010 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Fiat Stilo 1.2 16V Engine Fault. please help! Lukesfiatstilo Stilo 1 07-11-2010 18:14
(T) Stilo 1.6 16v engine fault. Milsey Stilo 2 16-08-2010 14:02
(G) 1.6 16v stilo loosing power, engine fault..?? musicrocks1000 Stilo 15 19-07-2009 22:27