Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 14-12-2010   #1
Join Date: Apr 2010
Posts: 22
Thanks: 0
Trader Rating: 0
Finland 
MAP Sensor, Stilo 1.2 2002

Hi again...

Missus took the car to the garage to fix the exhaust flex joint leak, and when she left at work the engine fault light came on. I said that ask the mechanics to read/reset the fault codes, and code P0105 came up - MAP sensor circuit intermittent.

As the engine fault light was on, car ran as normal - no stalling or loss of power.

The garage removed the fault codes and it's been fine for a few weeks now. Until today the engine fault light came on again. No apparent problems as how the car runs (no stalling or loss of power etc.)

I suspect that the sensor is faulty, why would it have ran fine for weeks before the problem reappearing. It has been quite cold here (over -20C) and the other time the engine was started without the block heater.

The garage wants over 200 euros for the MAP sensor, but I've read some horror stories here that it may not be the culprit.

So, what things I need to check (I've already ordered the OBDII-USB cable too)
Sensor wiring? Any connectors between ECU and MAP?
Air filter?
Throttle body?
Check how closely throttle body sensor and MAP sensor outputs follow each other?
Spark plugs?
If the sensor is faulty, should the car run rougher and exprience the loss of power or have stalling issues?
May the cold weather have something to do with this? Engine breather partially blocked?
Anything else?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mastus is offline Reply With Quote Quote 
Old 14-12-2010   #2
Join Date: May 2006
Posts: 886
Thanks: 105
Trader Rating: 0
yellowstilo has donated!
Netherlands 
Re: MAP Sensor, Stilo 1.2 2002

i had P0105 fault codes with stalling engine after cold stard, replaced the MAP sensor but this didn't cure the fault.
checked earth connections, wiring loom,spark plugs and coils but found no anomalities.
Then i checked the throttle body, it was rather dirty inside (looked like black tar deposit) - cleaned it thoroughly and lubricated the butterfly axle and it seems this solved my problem.
I have to start and drive for some more days in cold wheather to be sure but at the moment i'm rather confident the dirty throttle body caused my P1015 faults.
Always worth trying , will only cost you some time and cleaner....
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

yellowstilo is offline Reply With Quote Quote 
Old 22-12-2010   #3
Join Date: Apr 2010
Posts: 22
Thanks: 0
Trader Rating: 0
Finland 
Re: MAP Sensor, Stilo 1.2 2002

Oh well...

She got home and engine fault light and message gone.
It's been little warmer here since then and no problems.

Now it's -23C and forecast told that tomorrow it's going to be -30C. Let's hope that engine breather won't freeze and no more cryptic "engine fault" warnings...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mastus is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) map sensor for fiat stilo johnathan19 Stilo 29 16-11-2014 10:07
(G) Map Sensor And cleaning 2.4 stilo Kewi333 Stilo 1 23-06-2010 07:03
(T) MAP Sensor - 1.6 3Dr Stilo Eddster Stilo 8 22-02-2009 12:31