Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 04-09-2009   #1
Join Date: Sep 2009
Posts: 8
Thanks: 0
Trader Rating: 0
Netherlands 
Unhappy Parrot MK6000 & Loose connection error

I've installed a parrot MK6000 in my Fiat stilo. About 1 out of 10 times when the parrot unmuted the radio I got a "Loose connection" error on my Stilo dashboard.


The suddenly after about a week the parrot died. I got a new one, and this time I decided to let a professional install the parrot. But now I still get the "Loose connection" error, and I'm affraid it will kill my parrot again eventually.

The parrot works fine (apart from stuttering audio from my 3GS once in a while), and it shuts down properly after removing the key from ignition.


Can anyone shed some light on this problem? It wil be greatly appreciated!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

generator is offline Reply With Quote Quote 
Old 06-09-2009   #2
Join Date: Sep 2009
Posts: 8
Thanks: 0
Trader Rating: 0
Netherlands 
Re: Parrot MK6000 & Loose connection error

Update: When the error pops up, the speed indicator goes flat.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

generator is offline Reply With Quote Quote 
Old 07-09-2009   #3
It's about GO! not SHOW!
 
Argonought's Avatar
Join Date: Sep 2005
Location: POOLE, Dorset
Posts: 7,335
Thanks: 340
Blog Entries: 1
Trader Rating: 0
Argonought has donated!
United Kingdom 
Re: Parrot MK6000 & Loose connection error

Sounds very much like you've interfered with the CAN network.

There are two connections (?) on the oem radio which should never be wired to anything else
__________________
------------------------------------------------------
Stilo Dynamic 5 door JTD {150} 02 model in Metallic Grigio Steel with Skyroof & 16" Alloys Mods: New standard springs all round; Tyres: FALKEN ZIEX ZE912; Oil: Mobil 1 TD 0W-40 fully synthetic
Argonought is offline Reply With Quote Quote 
Old 07-09-2009   #4
Join Date: Sep 2009
Posts: 8
Thanks: 0
Trader Rating: 0
Netherlands 
Re: Parrot MK6000 & Loose connection error

Hm... do you know which connections, so I can check if they're wired to anything else?

Thanx
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

generator is offline Reply With Quote Quote 
Old 07-09-2009   #5
It's about GO! not SHOW!
 
Argonought's Avatar
Join Date: Sep 2005
Location: POOLE, Dorset
Posts: 7,335
Thanks: 340
Blog Entries: 1
Trader Rating: 0
Argonought has donated!
United Kingdom 
Re: Parrot MK6000 & Loose connection error

__________________
------------------------------------------------------
Stilo Dynamic 5 door JTD {150} 02 model in Metallic Grigio Steel with Skyroof & 16" Alloys Mods: New standard springs all round; Tyres: FALKEN ZIEX ZE912; Oil: Mobil 1 TD 0W-40 fully synthetic
Argonought is offline Reply With Quote Quote 
Old 08-09-2009   #6
Join Date: Sep 2009
Posts: 8
Thanks: 0
Trader Rating: 0
Netherlands 
Re: Parrot MK6000 & Loose connection error

Thanks, i'll have a look!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

generator is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Won't Start & Loose Connection Problem [ECU bad contact] White_Rabbit Stilo 15 03-09-2014 15:53
(T) Loose Connection juan Stilo 6 10-12-2010 10:08
(T) loose connection on 2.4 anthonytutton Stilo 25 29-09-2007 21:45