Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 16-12-2008   #1
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Stilo electrical problem + warm starting problem

Driving to work today and although i have the heater on, i get a cold blast of air across my neck...

Look across and the passenger side window is completely down...

Try to raise it via the control panel on drivers side and no response. Lean across and manage to raise via the passenger side. Happens several other times on the trip with varying results from the passenger and drivers side switches.

Get to work and i think its the drivers side control panel. Pop it out and start wiggling the wires... hear clicking from the passenger side. Not sure if its the control panel itself or the loom.... anyone had this before?

Also, notice when the car is warm it struggles to catch and this results in having to hold it for longer to get it to start... any ideas? Rarely happens when cold.

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Old 16-12-2008   #2
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Is the lack of replies because no0one knows or because its just not that common a problem or cause no0one likes me

Only day i have for looking at this is thursday morning, so really looking for an idea on how to attack this!!

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Old 16-12-2008   #3
Join Date: Aug 2007
Location: Bury
Posts: 263
Thanks: 4
Trader Rating: 0
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Starting sounds like typical crank sensor problem, have a search, there is a massive thread on it
__________________
Moire black 5dr Stilo 1.9JTD [FONT=Arial]17 inch multispokes and a skyroof[/FONT]
kris lee is offline Reply With Quote Quote 
Old 16-12-2008   #4
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Oh right.....

How difficult to replace? Any idea what the thread is called? Thanks.

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Old 16-12-2008   #5
Super LOL!
 
Stu DemonD's Avatar
Join Date: Sep 2003
Posts: 23,471
Thanks: 426
Trader Rating: 1
Stu DemonD will never be forgotten
Stu DemonD has donated!
Jigsaw: Chess Pieces Champion
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Quote Originally Posted by h2ypr View Post
Is the lack of replies because no0one knows or because its just not that common a problem or cause no0one likes me
You bumped this after 5 hours! I suggest next time you give people a chance to reply, ok
__________________
See you next Tuesday
Stu DemonD is offline Reply With Quote Quote 
Old 17-12-2008   #6
PNL
Banned
 
PNL's Avatar
Join Date: Nov 2005
Location: In my house
Posts: 13,715
Thanks: 243
Trader Rating: 0
PNL has donated!
United Kingdom 
Cool Re: Stilo electrical problem + warm starting problem

Firstly check the plug situated on the front door frame..lift the round clip and pull ..check for bad connections and refit..that was my problem when it happened to me.. other than that ..when the appropriate door switch is pressed [left or right] the appropriate window motors receives power to the relevant door node which receives the command [open/close] from the switch on the door panel..the door node is protected by a special fuse housed in the under dash fuse unit and controlled by a relay also in the unit.so check these out and if no success is got then a diagnostic test of the circuit will be needed[I'm sure Decks can help you with how to do a circuit test] hope that help mate..

Sorry for the late reply..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PNL is offline Reply With Quote Quote 
Old 17-12-2008   #7
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Quote Originally Posted by PNL View Post
Firstly check the plug situated on the front door frame..lift the round clip and pull ..check for bad connections and refit..that was my problem when it happened to me.. other than that ..when the appropriate door switch is pressed [left or right] the appropriate window motors receives power to the relevant door node which receives the command [open/close] from the switch on the door panel..the door node is protected by a special fuse housed in the under dash fuse unit and controlled by a relay also in the unit.so check these out and if no success is got then a diagnostic test of the circuit will be needed[I'm sure Decks can help you with how to do a circuit test] hope that help mate..

Sorry for the late reply..
Thanks dude.

Didnt happen today but no illumination on the control panel. I'm sure its the control panel...have ordered a replacement panel, and asked for wiring to be included so hopefully its one or the other. Seems like bad connection inside the unit or the wiring to be honest.

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Old 17-12-2008   #8
PNL
Banned
 
PNL's Avatar
Join Date: Nov 2005
Location: In my house
Posts: 13,715
Thanks: 243
Trader Rating: 0
PNL has donated!
United Kingdom 
Cool Re: Stilo electrical problem + warm starting problem

Disconnect battery and reset ecu works as well.. if all this doesnt put you off stilo ownership nothing will and you are hard core member of the stilo massive..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PNL is offline Reply With Quote Quote 
Old 17-12-2008   #9
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Noone owns a fiat and expects it to work all the time...

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Old 17-12-2008   #10
Join Date: Aug 2007
Location: Bury
Posts: 263
Thanks: 4
Trader Rating: 0
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Quote Originally Posted by h2ypr View Post
Oh right.....

How difficult to replace? Any idea what the thread is called? Thanks.

Ross
Just search crank sensor fault and i'm sure it will come uo!!!
__________________
Moire black 5dr Stilo 1.9JTD [FONT=Arial]17 inch multispokes and a skyroof[/FONT]
kris lee is offline Reply With Quote Quote 
Old 19-12-2008   #11
Join Date: Oct 2006
Location: Glasgow
Posts: 8,120
Thanks: 308
Trader Rating: 3
ycming has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Quote Originally Posted by h2ypr View Post
Driving to work today and although i have the heater on, i get a cold blast of air across my neck...

Look across and the passenger side window is completely down...

Try to raise it via the control panel on drivers side and no response. Lean across and manage to raise via the passenger side. Happens several other times on the trip with varying results from the passenger and drivers side switches.

Get to work and i think its the drivers side control panel. Pop it out and start wiggling the wires... hear clicking from the passenger side. Not sure if its the control panel itself or the loom.... anyone had this before?

Also, notice when the car is warm it struggles to catch and this results in having to hold it for longer to get it to start... any ideas? Rarely happens when cold.

Ross
Easy fix mate, buy another sei or cinq. sell the stilo sorted!!!

Ming
__________________
Wanted : Nothing at the moment
ycming is offline Reply With Quote Quote 
Old 19-12-2008   #12
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

check A pillar loom connector, not sure about crank sensor though more like voltage problem if you need to crank it longer?
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 20-12-2008   #13
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Quote Originally Posted by T14086 View Post
check A pillar loom connector, not sure about crank sensor though more like voltage problem if you need to crank it longer?
Was checking it last night again, as it was playing up badly yesterday. Its definately the wiring as i've replaced the control unit. Moving the wiring causes the window to either click or actually move. I reckon the constant live for the illumination is touching the passenger side wires. So i'll probably need a new loom for that section. Anyone any idea of how long that section of wiring is?

As for cranking problem, i reckon its a fuel issue. Possibly dirty fuel filter.

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Old 20-12-2008   #14
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

just door loom, about 45 ish & not hard to fit.
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 22-12-2008   #15
punto then coupe
Join Date: Dec 2005
Location: Halfway
Posts: 1,102
Thanks: 2
Trader Rating: 0
h2ypr has donated!
United Kingdom 
Re: Stilo electrical problem + warm starting problem

Quote Originally Posted by T14086 View Post
just door loom, about 45 ish & not hard to fit.
Superb!!!

I'll strip the door down tommorow and have a check, but if i cant get one from a scrap car, i'll nab one from fiat!!

Thanks for your help people.

As for the starting problem... occasional "engine fault" message appearing at start up and then disappears immediately. Crank sensor looks like its on the way out

Ross
__________________
h2ypr is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Starting problem Stilo 1.2 850kd Stilo 7 11-04-2008 10:12
(T) Warm Start Problem kegg Punto (Mk2/2b) 0 24-09-2007 19:24
(T) warm start problem Dave lee Cinquecento / Seicento 5 19-11-2006 20:59
(G) warm start problem with uno 1.7 Shafiq Ahmad Uno 2 27-02-2006 15:36
(T) Problem starting when warm (Bosch SPI) cammy Uno 3 30-06-2003 15:28