Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 29-11-2008   #16
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

at last got my stilo back an all is fine, except the,credit cards dinted for 550, is it normal for the ecu to fail at 40,000 miles on the stilo, my moms had issues with 2 ecu failures on 2 diff. punto,s over the last 3 years, all lower mileage than my car ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 29-11-2008   #17
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: 1.6 no throttle, limp mode [ECU?]

changed quite a few stilo ECU's....remember though what actually goes on inside them as basically its a computer and when you consider that they are actually reliable compared to the old points/dis/condensor systems!
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 29-11-2008   #18
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.6 no throttle, limp mode [ECU?]

so early in their life though, never had to jump start my car or anything so no reason for a "spike" or anything to cause failure, anyhow I am going to enjoy having my black baby back, at least for the next 40,000miles or more prob. free driving, and again thanks everyone for their input, its what makes this forum what it deserves,
respect.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 01-12-2008   #19
Bravo 1.8 HLX FTW
 
The Sultan's Avatar
Join Date: Jul 2006
Posts: 3,851
Thanks: 298
Trader Rating: 0
The Sultan has donated!
United Kingdom 
Re: 1.6 no throttle, limp mode [ECU?]

Quote Originally Posted by fennbeam View Post
so early in their life though, never had to jump start my car or anything so no reason for a "spike" or anything to cause failure, anyhow I am going to enjoy having my black baby back, at least for the next 40,000miles or more prob. free driving, and again thanks everyone for their input, its what makes this forum what it deserves,
respect.
replaced quite a few bravo 1.6 ecus for spikes and we always find someone is using the incorect plugs or cheap silicone leads so it's posible for that to happen just depends on how the coils and ecu are set up on them how powerful they are

the 1600s were the first fiats to start using really powerful coils realy

can remember one very clearly were someone fit completely incorect plugs and the ecu died within a few miles he was actually driving to the garage to ask about this strange missfire he had under load right after he had the work done
__________________
500 door handles fit bravo well chuffed
The Sultan is offline Reply With Quote Quote 
Old 01-12-2008   #20
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.6 no throttle, limp mode [ECU?]

car is std. an with bosch std. replacement plugs, I have no problem with bosch or ngk plugs, I rate them both, although ngk is a better all round plug
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 15-12-2008   #21
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
Unhappy Re: 1.6 no throttle, limp mode [ECU?]

ok had the car back for a couple of weeks now an it does not seem to have the same "get up an go" as before, lacking slight bottom end power, also difficult to nicely pull away when cold, wants to almost stall, no fault codes, or big changes in fuel consumption any one got any ideas, was the new ecu not completely/ correctly programmed ??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 09-03-2009   #22
Join Date: Mar 2009
Posts: 2
Thanks: 0
Trader Rating: 0
Re: 1.6 no throttle, limp mode [ECU?]

Hi there

I just wanted to tell you that your fault is likely to a dodgy coil pack in number 4 cylinder it causes interference with the ecu , you could try and swop them around. The best bet is ti change it for an original only not a motor factors????
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nathen is offline Reply With Quote Quote 
Old 09-03-2009   #23
Join Date: Sep 2007
Location: Alkmaar, Netherlands
Posts: 1,537
Thanks: 84
Trader Rating: 0
Netherlands 
Re: 1.6 no throttle, limp mode [ECU?]

Quote Originally Posted by fennbeam View Post
ok had the car back for a couple of weeks now an it does not seem to have the same "get up an go" as before, lacking slight bottom end power, also difficult to nicely pull away when cold, wants to almost stall, no fault codes, or big changes in fuel consumption any one got any ideas, was the new ecu not completely/ correctly programmed ??

On mine someone managed to not properly connect the intakepipe (airboxside). Took me a while to figure that out.....
Since I tightened the clamp mine runs much better

gr J
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

A3jeroen is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Stilo in Limp Mode pachamama Stilo 10 29-11-2011 15:43
(T) Limp home mode gtturbs Punto (Mk2/2b) 1 11-11-2008 19:11
(G) Auto gearbox getting into limp mode? Ulysse16V Ulysse 0 06-03-2007 05:31
(G) 2.0 hdi problems - limp mode??? fiatone Scudo 1 01-03-2007 20:34
(G) MP3 Player - Shuffle (MIX) mode, Repeat mode etc. Honzus Grande Punto 29 26-06-2006 19:22