Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 01-03-2007   #1
Join Date: Feb 2007
Posts: 19
Thanks: 0
Trader Rating: 0
United Kingdom 
2.0 hdi problems - limp mode???

The other thing my mate tells me, is that the engine keeps going into what he calls Limp mode.

Where he can hear hissing when the turbo is on boost and then 10secs later it goes into Limp mode where the engine will not rev anymore than 2500rpm and the engine mangement light is on, also its drinking fuel.
He has checked the hoses etc to his best, finding everything ok.

Any Ideas what could be causing this problem.

thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiatone is offline Reply With Quote Quote 
Old 01-03-2007   #2
Join Date: Feb 2007
Posts: 19
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 2.0 hdi problems - limp mode???

Ok I've found the fault.

Its the rubber hose joint from the turbo to the plastic pipe going under the engine to the intercooler, it was split.

New hose fitted and its flying again.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiatone is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) MAF problems! marea 2.0 155 -01 scoobysweden Marea 11 29-01-2007 22:52
(T) Stilo Secret Menus & Settings Access Rich Stilo 0 16-08-2006 16:57
(T) intermittent start problems with Tipo 2.0 16v goran Tipo (Classic) 4 26-04-2006 11:35
(T) Tipo 2.0 16V problems - Central locking, window etc. Coolsmarti Tipo (Classic) 5 24-08-2005 16:46
(T) 2.0 20v Injector problems muzzer Marea 3 16-06-2005 20:09