Register Login
endrop - for all your online needs
Reply
 
Thread Tools Search this Thread
Old 23-09-2019   #1
Join Date: Sep 2019
Posts: 1
Thanks: 0
Trader Rating: 0
Netherlands 
ritmo 130 tc stalls while driving

hello Fiat and Ritmo friends,

after mounting a new electric fuel pump, while the old one leaked, i now suddenly have a problem. the car starts ok, after driving 500 metres the car stalls and engine stops. Both swimmer rooms are empty. Looks that the pump cannot hold the fuel level in the twin carburators. ( Solex ADDHE, 40 mm original carbs), carburators are cleaned and have complete new gasket set.

Car has been running on dynojet roller to adjust the carburators for several hours, no problem. The fuel pump had a leakage and therefor replaced with Bosch 12V/ 3 bar pump.

Pressure regulator is old but it operates ok.

I have read some items about this specific problem on a german forum.
But I already tried a lot of things, but everytime the car starts ok, after driving it stalls.

Pump is engaged continuously, I can hear it running, also checked voltage of fuel pump while operating (12,2 Volts)..

Does someone had this problem to? I'm out of suggestions....

Regards Marc
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Ritmo130TC is offline Reply With Quote Quote 
Old 29-12-2019   #2
Join Date: Dec 2019
Posts: 7
Thanks: 0
Trader Rating: 0
Netherlands 
Re: ritmo 130 tc stalls while driving

hi, it seems similar to the problem i have with my strada 1,9 jtd. Also starts and runs fine but shuts down after a short time. They changed the rail sensor, but it still has problems and they are now offering to change the high pressure fuel pump.
No idea if this solves the problem though.

Did you fix your car by now? What was the cause?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

TomKruis is offline Reply With Quote Quote 
Old 29-12-2019   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 21,601
Thanks: 763
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by TomKruis View Post
hi, it seems similar to the problem i have with my strada 1,9 jtd. Also starts and runs fine but shuts down after a short time. They changed the rail sensor, but it still has problems and they are now offering to change the high pressure fuel pump.
No idea if this solves the problem though.

Did you fix your car by now? What was the cause?
Hi and welcome

Confusingly..

There was a 1970/80's petrol car

And a 1990's pick.up / truck.. diesel in your case.

The 1.9 jtd was fiats main diesel from 1998 to 2005
Found in.. punto. Stilo bravo/a marea

Plenty of information on here for that motor

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is online now Reply With Quote Quote 
Old 29-12-2019   #4
Join Date: Dec 2006
Location: Southampton, Hampshire
Posts: 4,073
Thanks: 291
Trader Rating: 0
s130 has donated!
United Kingdom 
Re: ritmo 130 tc stalls while driving

On the 130TC the fuel pump is engaged/disengaged by an oil pressure sensor.

The design is there to prevent engine damage when the oil pressure drops.

I would check that this pressure switch (I think located on the oil filter housing assembly) is working OK and also not clogged up.

On our 130TC I have a bypass switch that we engaged to bypass this pressure switch and allow the fuel pump to fully prime and fill the Solex float chambers with fuel. Once the engine has started we disengage the bypass.

The Solex carbs tend to evaporate fuel quite quickly so when left standing for a while then the engine has to be cranked quite hard to build up oil pressure to enable the fuel pump. Real pain in the butt.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

s130 is offline Reply With Quote Quote 
Old 04-01-2020   #5
Join Date: Aug 2011
Posts: 49
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: ritmo 130 tc stalls while driving

I use my car 5 days a week and when its left for a while really is a pain to start . Sometimes to save the battery i wil pull the bonnet and take off the low oil pressure switch to prime the pump . When i am in the car and driving i have the back seat down most of the time and can just about here my pump running which you should also be able to do . In you rcase i would suggest you have a look at the fuel pump relay as this is most likely causing you the problem . Its under you leg beside the auxillary fuse box .Your voltage at the pump should be 13.5volts plus
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by abarth130tc; 04-01-2020 at 19:56.
abarth130tc is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Punto won't start and then stalls when driving. FiatLadyee31 Punto (Mk2/2b) 4 26-09-2013 19:36
(G) Fiat Abarth Ritmo 130 TC for sale fiat abarth Ritmo / Strada 7 14-07-2011 15:00
Ritmo Abarth 130 TC. (Canada). Morty Mort Auction Watch 3 19-10-2006 20:11
(T) Ritmo 130 TC Recaros in leather Domo Ritmo / Strada 8 04-07-2005 23:24