Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 29-06-2014   #1
Join Date: Jun 2014
Posts: 2
Thanks: 0
Trader Rating: 0
South Africa 
Fiat Strada EL 1200 Wiring issue

Hi All, Hoping there is someone out there that can assist. I have the 1200 Fiat Strada EL. For some time now I've experienced a problem with the indicators. When I have no headlights on or if I don't touch the brakes, They work fine. If I indicate and touch brakes they stop working. Also notice that when I hold in the brake pedal I get a low glow on the indicator bulb. Looks to me like a bad earth but don't know where to start. Any body with suggestions?

Thanking in advance
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

grsonline is offline Reply With Quote Quote 
Old 04-07-2014   #2
`
Join Date: Jan 2013
Posts: 6,117
Thanks: 183
Trader Rating: 0
flisko has donated!
United Kingdom 
Re: Fiat Strada EL 1200 Wiring issue

Quote Originally Posted by grsonline View Post
Hi All, Hoping there is someone out there that can assist. I have the 1200 Fiat Strada EL. For some time now I've experienced a problem with the indicators. When I have no headlights on or if I don't touch the brakes, They work fine. If I indicate and touch brakes they stop working. Also notice that when I hold in the brake pedal I get a low glow on the indicator bulb. Looks to me like a bad earth but don't know where to start. Any body with suggestions?

Thanking in advance
this looks excatly the same problem as i had on my punto mk1, turned out to be corroded and dirty rear metal bulbs holder, so the bulbs for the indicator wasnt making good contact with the holder so when you press on the brake they stop working, what i did was clean all the bulbs and their metal holders and problem went away
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

flisko is offline Reply With Quote Quote 
Old 04-07-2014   #3
Join Date: Jun 2014
Posts: 2
Thanks: 0
Trader Rating: 0
South Africa 
Re: Fiat Strada EL 1200 Wiring issue

Quote Originally Posted by flisko View Post
this looks excatly the same problem as i had on my punto mk1, turned out to be corroded and dirty rear metal bulbs holder, so the bulbs for the indicator wasnt making good contact with the holder so when you press on the brake they stop working, what i did was clean all the bulbs and their metal holders and problem went away
Hi flisko,
Thanks for the response had a look at the globes and holders but no visible corrosion present. Did however find a globe that had blown one issue fixed.. without even using the indicators ive noticed that when I turn on the headlights and press the brakes the fog light button on the center console lights up with out pressing it on. Weird issue this...to me it sounds as if a plug somewhere has corroded but cant seem to track it down.. Regards
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

grsonline is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
weird wiring issue in fiat seicento 900cc adrenaline I.C.E 1 06-06-2011 19:09
Fiat Punto Sporting 1.4 (2004) Wiring issue F4810 I.C.E 1 26-04-2010 21:48
(T) Fiat Punto Sporting 1.4 (2004) Wiring issue F4810 Punto (Mk2/2b) 0 26-04-2010 20:34
punto mk1 '96 1200 wiring diagram 126paul Tech Talk 0 08-10-2009 17:18