Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools Search this Thread
Old 11-10-2018   #1
Join Date: May 2018
Posts: 32
Thanks: 1
Trader Rating: 0
United Kingdom 
Please help!!!

My 2011 95bhp 1.3TD manual Qubo threw up the engine management light and small warning triangle while my Wife was driving home last night.

The car still drove fine but I did notice that the radiator fan was on high speed when she pulled on the drive.

I read the codes and got just one P0512 Starter Signal Circuit. Does anyone know the cause of this and a cure please ?

Many thanks Noony
Likes Qube O liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Noony; 11-10-2018 at 09:12. Reason: Added more to the code
Noony is offline Reply With Quote Quote 
Old 11-10-2018   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 28,166
Thanks: 1099
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Noony View Post
My 2011 95bhp 1.3TD manual Qubo threw up the engine management light and small warning triangle while my Wife was driving home last night.

The car still drove fine but I did notice that the radiator fan was on high speed when she pulled on the drive.

I read the codes and got just one P0512 Starter Signal Circuit. Does anyone know the cause of this and a cure please ?

Many thanks Noony
Hi.
How old is the battery?


Could just be a poor supply . Leading sensor voltage to drop on a cold start.


Does that code feature elsewhere on the forum?
Likes Qube O liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 12-10-2018   #3
Join Date: May 2018
Posts: 32
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Please help!!!

Hi there, thanks for your reply. I can confirm the battery is in good condition.

I cleared the code and drove it all day yesterday and she didn't miss a beat, I'll be out in her again today so I'll see if it comes up again.

Cheers Noony.
Likes Qube O, varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Noony is offline Reply With Quote Quote 
Old 16-10-2018   #4
Join Date: May 2018
Posts: 32
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Please help!!!

Just a quick update, I have driven her since with no problems at all including a 90 mile trip up the M1 at cruising speeds so touch wood all is good.
Likes Qube O, varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Noony is offline Reply With Quote Quote 
Old 26-02-2021   #5
Join Date: May 2018
Posts: 32
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Please help!!!

Well after a couple of years of this code P0512 not showing its face, it has appeared again!!

My Qubo drive faultlessly again so I have cleared the code with my OBDII Scanner and will see if it re appears.

Take care folks.
Likes jackwhoo, Qube O liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Noony is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump