Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 26-10-2003   #1
Join Date: Oct 2003
Location: Stoke On Trent, United Kingdom.
Posts: 5
Thanks: 0
Trader Rating: 0
Punto 55SX Temperature problem!?!?

Hello, newcomer in need of a bit of guidance with a problem.
A few weeks ago i began to notice my temperature gauge shooting to higher heights. I tried to work it out and noticed that my cooling fan was not kicking in either. Two days later I found a pool of water under my car which I later found following a bit of Haynes manual advice to be a water pump problem. This has since been replaced along with a new thermostat and a radiator switch in the hope that it would kick my fan in. Even though all these things have been done, it is still boiling water, the gauge still heading for it's limit and the fan still doesn't kick in.
Anyone got any inspiration please?????
P.s. No signs of oil in water and vice-versa and checked fuses.

Help Me!!!! :-D
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nodgers is offline Reply With Quote Quote 
Old 26-10-2003   #2
Became old and sensible
 
MrDerv's Avatar
Join Date: Aug 2003
Location: Durham
Posts: 2,664
Thanks: 21
Trader Rating: 0
MrDerv has donated!
United Kingdom 
Faulty thermostat. it's not letting the coolant thru to the radiator (which is where the temp switch for fan is) and boiling in the engine. could also be an air block stoppong the water circulating.

Check the thermostat first though


Wanted: Exhaust for my Cinq Sporting! PM me!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

MrDerv is offline Reply With Quote Quote 
Old 26-10-2003   #3
Join Date: Oct 2003
Location: Stoke On Trent, United Kingdom.
Posts: 5
Thanks: 0
Trader Rating: 0
Just got off the phone to someone who said the same two things, thank you very much for your quick response it's greatly appreciated.

Help Me!!!! :-D
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nodgers is offline Reply With Quote Quote 
Old 26-10-2003   #4
Join Date: Oct 2003
Location: Stoke On Trent, United Kingdom.
Posts: 5
Thanks: 0
Trader Rating: 0
In a bit of a pickle still, as the manual has gone walkies. How will I know if it is the thermostat(which is new from halfords) that is the fault? and if I have got an air blockage, how do I bleed it out of the system?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nodgers is offline Reply With Quote Quote 
Old 26-10-2003   #5
Became old and sensible
 
MrDerv's Avatar
Join Date: Aug 2003
Location: Durham
Posts: 2,664
Thanks: 21
Trader Rating: 0
MrDerv has donated!
United Kingdom 
unsure about the bleeding as the cooling setup is different from a cinq although it's the same engine. the thermostat has to be removed and suspended in a large container (glass preferably so you can see it) of hot water and you should see the mechanism move. if it doesn't, it's knacked and need a new one.

Find the haynes manual and it'll tell you in detail how to test the thermostat and bleed the coolant. hope that helps



Wanted: Exhaust for my Cinq Sporting! PM me!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

MrDerv is offline Reply With Quote Quote 
Old 26-10-2003   #6
Join Date: Oct 2003
Location: Stoke On Trent, United Kingdom.
Posts: 5
Thanks: 0
Trader Rating: 0
Thanks managed to get my manual back from it's day out in a mates car boot, going to give it a try.
Thanks very much.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nodgers is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Solution to Punto 75 mk1 Engine Problem Tziallas Punto (Mk1) 8 10-09-2010 08:17
(T) Punto 55s -97 lambda problem? ice0018 Punto (Mk1) 7 06-06-2007 11:14
(T) Punto 75 SX '98 battery & electronic check problem zokipet Punto (Mk1) 3 22-02-2003 03:37