Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools Search this Thread
Old 25-03-2009   #1
Join Date: Mar 2009
Posts: 3
Thanks: 0
Trader Rating: 0
Mk1 punto starting issue

hi , i have a mrk 1 60s, last year after a shoppin trip i drove home, and parked up realised we'd forgotten something so i nipped out to get in it and it wouldnt turn over properly, it was slow reving, and lumpy as hell to the point i couldnt even drive it, soon after i got another car and thought sod it. came back to it yesterday and checked all the vitals, compression, spark changed the plugs and leads, it turned breifly and ran lumpy for 30 seconds and now it wont start at all any advice would be great as i need it running asap thanks guys
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

snakemad123 is offline Reply With Quote Quote 
Old 25-03-2009   #2
Join Date: Nov 2007
Posts: 215
Thanks: 3
Trader Rating: 0
United Kingdom 
Re: Mk1 punto starting issue

Running lumpy sounds like a symptom of dead/dying secondary coils!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jon_gordon is offline Reply With Quote Quote 
Old 26-03-2009   #3
Join Date: Mar 2009
Posts: 3
Thanks: 0
Trader Rating: 0
Re: Mk1 punto starting issue

where would i find this under the bonnet?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

snakemad123 is offline Reply With Quote Quote 
Old 26-03-2009   #4
Join Date: Nov 2007
Posts: 215
Thanks: 3
Trader Rating: 0
United Kingdom 
Re: Mk1 punto starting issue

They're attached to the right hand side of the engine.
They'll have two plugs on the left of them, 4 plugs on the right with leads going to the spark plugs at the back - you can't miss them!

Here's a picture of them removed

http://www.twenga.co.uk/offer/5804/8...105272879.html

You *may* have a cover over them, held down with a single bolt, IIRC.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jon_gordon is offline Reply With Quote Quote 
Old 26-03-2009   #5
Join Date: Nov 2007
Posts: 215
Thanks: 3
Trader Rating: 0
United Kingdom 
Re: Mk1 punto starting issue

Here's a better picture, attached to the engine!

http://jon-gordon.co.uk/gallery/coils.jpg
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jon_gordon is offline Reply With Quote Quote 
Old 26-03-2009   #6
Join Date: Mar 2009
Posts: 3
Thanks: 0
Trader Rating: 0
Re: Mk1 punto starting issue

i checked the spark last night and the spark was a strong blue also shocked my mate which was reasonably funny, we had one spark plug which was practically destroyed no gap at all , i have a feeling it might have something to do with a lack of fuel or water in the fuel? does anyone have a bit of time and a landline that they can have a chat about it with me?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

snakemad123 is offline Reply With Quote Quote 
Old 27-03-2009   #7
Join Date: Feb 2009
Location: sheffield
Posts: 8
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Mk1 punto starting issue

it could be a blocked fuel filter but it sounds to me as if the head gasket could be on its way out
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

wansk503 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Ongoing Starting issue MJET 1.9 alexh365 Grande Punto 17 17-07-2009 21:54
(G) mk1 punto not starting kizz Punto (Mk1) 9 23-08-2008 03:22
(T) engine starting issue sc4rf4ce Punto (Mk2/2b) 0 14-10-2007 22:55
(T) PUNTO MK2 MIA 1.2 8v starting issue??? Smyth Punto (Mk2/2b) 1 07-12-2006 15:53
(T) Punto MK1 Factory Alarm issue Lighfunkyone Punto (Mk1) 1 13-11-2006 21:55