Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 10-11-2010   #16
Join Date: Mar 2007
Location: Cornwall
Posts: 368
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

My problem on the mk1 punto 60 did turn out to be the speedo instrument itself as Mike salt posted. I found a replacement pod at a Scrapyard on e-bay. As the mileage was very similar I just swapped the while pods over. Cost me 20 for the pod and changeover involved 2 screws and 3 cable plugs. 5 minute job and perfect since(oh hell just tempted the fiat god)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiat_freak is offline Reply With Quote Quote 
Old 10-11-2010   #17
Join Date: Apr 2008
Posts: 16,587
Thanks: 911
Trader Rating: 0
Ziggy122 has donated!
Eggs Champion, Fruit Pairs Champion
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

i could be wrong mk1 could be cable

But if a new cluster sorted it - then i'd say its fair to believe it was the cluster at fault as stated

Ziggy
__________________
!!WANTED!! 3dr Mk2 Punto Roof Bars !!WANTED!!

Meet Bumble-Bee


Ziggy122 is offline Reply With Quote Quote 
Old 10-11-2010   #18
Join Date: Jan 2008
Location: Basingstoke, Hampshire
Posts: 181
Thanks: 3
Blog Entries: 1
Trader Rating: 0
Bully99 has donated!
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Quote Originally Posted by trey1984 View Post
Hi everyone!

im new on here so i apologise if this is posted somewhere it shouldnt be

i have a 1994 elx 90 cabrio, the speedo is not working at all and the fuel light is on constantly... the rev counter and other dash lights etc are all working as they should... just not the speedo...?? if any one can help id really appreciate it, i know my way around a car being brought up with 5 brothers and a dad who are all mechanics, unfortunately theyre all at the other end of the country! and i reckon asking an actual fiat fanatic would help me out a bit more

cheers in advance! Trey
Trey let us know if you still have instrument panel problems, cause I have just changed the panel of mine for a different style so have a working spare going.

Cheers

I

I
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bully99 is offline Reply With Quote Quote 
Old 23-10-2013   #19
Join Date: Oct 2013
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Quote Originally Posted by spf View Post
if you look at the back of the engine, roughly in the middle but slightly towards the passenger side, there should be a wire running to the back of the transmission - this connects to a plastic part (round top with tubular piece protruding into the engine) which has a 20mm nut connecting it to the transmission.

if you have a 1.2 8v its shown (and labeled) in the guides section - "where everything is on a 1.2fire engine" (would put the link in, but not allowed till I have 5 posts!)

You just need to undo the 20mm nut and lift off the speedo sensor. disconnect the wiring and rreverse the process with your replacement one. takes 2 mins!

only other thing that may be wrong there is that the actual speedo sensor unit connects to a plastic gear inside the transmission. to get this out, just below where you undid the 20mm speedo sensor nut is a small screw (about 8mm hex head) - loosen this off and lift out what is left in the hole where the speedo sensor was - there should be a metal sleeve and inside that a plastic gear. have a look at it and see if it's intact, especially where it connects to the speedo sensor - if it looks worn this may be your problem.

once you locate these it's really easy - I think the arrangement is basically the same on a 16v engine, but am open to correction on that.

the big question is - do you have ABS? If so, this all means nothing as the speedo works in a different way - by the sounds of your problem I'd guess not tho! seems far too similar to not be the same thing.

hope you get it sorted!
sorry to bring this up again, do you know on the back of the engine what the small circuit board is for? I have a slight idea, one wire was not attached am i right in thinking this can be the reason my speedo doesn't work?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mk1Madness is offline Reply With Quote Quote 
Old 25-02-2019   #20
Join Date: Oct 2014
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Just to add to this and to thank the previous posters who have saved me a lot of money! My Punto Mk1 1.2 developed the erratic speedo, sticking on 20 then zooming to 120 etc. On reversing it would wind up to 100 then on going forward lurch back to 20 with noise. Mine has no cable and is the electronic so guessed either the sensor on the gearbox or the dash end. The big clue was if I bashed the dash, it would sometimes clear the fault in the early days.
So I removed the dash, took off the cover then undid the 3 screws on the speedometer so it could come out. Between the speedometer and the main back of the unit where there is a thin electrical track matrix, there is a small PCB. Looking EXTREMELY carefully I found a tiny crack in the solder mount where one of the edge connectors goes onto the board. Soldered that back solid and the others for good measure then tightened the end of the 3 wires going onto the main back (one a screw and the other two small nuts) and re-assembled.
This has cured my problem completely. About a 30m job with no pitafalls. Hope that helps others and worth a check before buying replacement units.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fpwheel is offline Reply With Quote Quote 
Old 25-02-2019   #21
Join Date: Jul 2009
Location: blackwood
Posts: 104
Thanks: 11
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

My 75sx has this problem at the moment with been stuck at 20mph and then going off the clock etc. Was going to replace the Speedo sensor but will check instrument cluster first cheers Fpwheel
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

lampy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Fiat Punto MK1 speedo problems fiatpunto123 Punto (Mk1) 2 16-01-2011 16:08
(G) Mk1 Punto Speedo!! Mk1PuntoRyan Punto (Mk1) 3 24-07-2007 18:38
(T) MOT checks/usual problems? VUK Uno 13 12-06-2006 15:36
Fiat Punto Mk1 Speedo/clock Set With Revcounter. dave Auction Watch 0 10-02-2005 01:41