Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 05-05-2019   #1
Join Date: Oct 2017
Location: Edinburgh Scotland
Posts: 1,610
Thanks: 158
Trader Rating: 0
Pugglt Auld Jock has donated!
United Kingdom 
No slow speed on radiator fan

I was "messing about" with my Multiecuscan the other day and was trying out some of the component activations just for familiarization. When I plugged into my boy's Punto (2012 1.4 8valve Punto with air con) I found that I could drive the radiator fan at fast speed but nothing happens at slow speed. Is there a common reason for this - something which tends to fail more often than anything else? - I believe there is a resistor pack behind the radiator somewhere so I suppose that is favourite?

Thanks to anyone who may have an idea.
regards
Jock
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Pugglt Auld Jock is offline Reply With Quote Quote 
Old 05-05-2019   #2
Join Date: Oct 2017
Location: West Yorkshire
Posts: 1,605
Thanks: 74
Trader Rating: 0
chris3234 has donated!
United Kingdom 
Re: No slow speed on radiator fan

I'd also go for the resistor pack given how it only works at full speed simeler to how cabins fans normally work only at full Speedo when they faul
Likes Pugglt Auld Jock liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

chris3234 is online now Reply With Quote Quote 
Old 05-05-2019   #3
Join Date: Oct 2017
Location: Edinburgh Scotland
Posts: 1,610
Thanks: 158
Trader Rating: 0
Pugglt Auld Jock has donated!
United Kingdom 
Re: No slow speed on radiator fan

Great minds think alike then. Thanks Chris. I suppose that in that position it's going to be quite exposed too? so a dodgy connection is quite likely too.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Pugglt Auld Jock is offline Reply With Quote Quote 
Old 07-05-2019   #4
Join Date: May 2011
Location: Norfolk UK
Posts: 9,690
Thanks: 437
Blog Entries: 8
Trader Rating: 0
United Kingdom 
Re: No slow speed on radiator fan

Most cars have the resistor attached to the plastic fan cowling somewhere, if they don’t have two separate fans. Not sure where it would be on the Evo to be honest.
__________________
Maker and voice behind the YouTube channel PuntoHowTo 10k subscribers canít be wrong

And now the owner of a shiny new PuntoHowTo Drivetribe
AndyRKett is offline Reply With Quote Quote 
Old 07-05-2019   #5
formerly PuntoR60SX
 
Pickwick's Avatar
Join Date: Oct 2005
Posts: 236
Thanks: 37
Trader Rating: 0
Pickwick has donated!
United Kingdom 
Re: No slow speed on radiator fan

In this photo of a radiator and fan assembly from a 2010 Punto Evo 1.4 (p/n 51797134) the resistor pack looks to be mounted in the top corner at the passenger side:

Click image for larger version

Name:	Punto_Evo_1-4_Radiator.jpg
Views:	13
Size:	142.6 KB
ID:	200176

In close-up:

Click image for larger version

Name:	Punto_Evo_1-4_Radiator_Resistor.jpg
Views:	10
Size:	92.7 KB
ID:	200178

Pictures sourced from here.
Thanks Pugglt Auld Jock thanked for this post
Likes varesecrazy, Pugglt Auld Jock liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Pickwick is offline Reply With Quote Quote 
Old 07-05-2019   #6
formerly PuntoR60SX
 
Pickwick's Avatar
Join Date: Oct 2005
Posts: 236
Thanks: 37
Trader Rating: 0
Pickwick has donated!
United Kingdom 
Re: No slow speed on radiator fan

Picture from the other side:

Click image for larger version

Name:	Punto_Evo_1-4_Radiator_Fan_Cowling.jpg
Views:	15
Size:	66.9 KB
ID:	200180

Sourced from here.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Pickwick is offline Reply With Quote Quote 
Old 09-05-2019   #7
Join Date: Oct 2017
Location: Edinburgh Scotland
Posts: 1,610
Thanks: 158
Trader Rating: 0
Pugglt Auld Jock has donated!
United Kingdom 
Re: No slow speed on radiator fan

Thanks Pickwick. Looking at the condition of that one I'd say ours has to be the prime suspect. Very grateful for your illustrations. A picture paints a thousand words!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Pugglt Auld Jock is offline Reply With Quote Quote 
Old 11-05-2019   #8
Join Date: Apr 2011
Location: Near the M4
Posts: 20,407
Thanks: 723
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: No slow speed on radiator fan

That APPEARS to be just back from the slam panel : accessible


Do let us know jock.

Great pics thanks @Pickwick
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) radiator fan not working at high speed puntomjd Grande Punto 4 24-08-2014 10:24
(T) low speed radiator fan problem-doplo donbigtoe Doblo 6 12-05-2010 21:49
(T) Radiator Fan Two Speed Wiring saibeml Uno 0 28-09-2009 10:05