Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 11-11-2015   #1
Join Date: Nov 2015
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Exclamation Fiat Punto TwinAir cold start issues

Hi all,

Just looking for some advice. I bought my Fiat Punto TwinAir in June 2015. The car has been absolutely fine up until about 2 months ago. In a morning from a cold start, the whole car shakes vigorously for 10 seconds, goes to normal for about 15 seconds and this repeats until the engine has warmed up, which is something it has never done before.

I've also noticed from cold starts it is having power issues. When I set off to drive this morning, I drove the car into third gear and then all of a sudden it started to jerk, a bit like when a car kangaroos - slipped it back into second, and then third and it improved it, but could still feel something was not quite right with how it was driving.

At the moment, I am having to sit in the car 15 mins from a cold start to stop this happening. I took it back to the garage I purchased it from, thinking it might be coil pack or spark plugs. They kept it overnight and tested and said 'we've tested it and cannot find anything wrong with it, but we've reset everything..' what ever that means.

There is something clearly wrong with the car, but I'm not mechanically minded in the slightest. The car sounds horrendous when started from cold, which it did not when I bought it and it seems they are fobbing me off!!

Any tips on what I could do or ideas on what it could be? Car's still has warranty, so was maybe thinking of taking it to another garage to see what they think!

Sorry for the long rant
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

kirby11 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Panda Twinair Stop Start issues Uglyscotsguy Panda 15 04-12-2013 11:22
Nissan Primera cold start\idling issues dan-the-man Non-FIAT 3 31-05-2013 00:52
(T) cold start issues moather Ulysse 0 06-05-2011 21:02
(T) Here we go again..cold start/HC issues ralphtown Cinquecento / Seicento 11 18-03-2010 15:01
1.4 S 12v cold running/start issues Joseph FIAT Boo Archives 7 07-03-2006 14:46