Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 13-01-2007   #1
Join Date: Dec 2006
Posts: 5
Thanks: 0
Trader Rating: 0
major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

i have a major problem with my car, it doesn't work anymore, i have taken it to a garage and guess what they have had it a week and still don't know whats wrong with it!!!!!!. its a 1996 mk1 punto 75sx, it starts up and moves but it is chugging and struggles to get over 30 mph, imagine how happy i was for this to happen to me on the motorway, and also its fine for about 15 min if i turn the engine off and let it rest.

now here is the tricky bit, the carburetor is fine , the fuel pipes are fine the spark plugs are brand new and working fine, the injectors are not blocked or damaged in any way, the clutch is fine and so is the gear box, the accelerator is fine, the coil is fine and all of the electrics have been checked three times!!!!! but still it isn't working properly.

has anybody any idea as to what it could be????????????

i would appreciate any ideas no matter how small or insignificant it may seem, cause it usually is something small thats the problem!!!!!!!

thanks for you time
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

simp0388 is offline Reply With Quote Quote 
Old 13-01-2007   #2
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Quote Originally Posted by simp0388 View Post
carburetor


Was it a fiat garage?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T14086 is offline Reply With Quote Quote 
Old 13-01-2007   #3
Join Date: Dec 2006
Posts: 5
Thanks: 0
Trader Rating: 0
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

no it wasn't the nearest fiat garage is quiet far away, and this chap is just a few blocks away, however he did change the carburetor but it made no difference. however all the electrics were checked twice by a fiat electrician, its defiantly a head scratcher!!!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

simp0388 is offline Reply With Quote Quote 
Old 13-01-2007   #4
Join Date: Dec 2006
Location: Cambs/Norfolk border
Posts: 955
Thanks: 10
Trader Rating: 0
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Maybe the problem is that he changed the carburettor.

T14086....do the ECU's have a 'limp mode' or am I think of a different fiat?

Dead fuel pump? Blocked fuel filter? Fuel cut-off been switched on?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

crabbo_1 is offline Reply With Quote Quote 
Old 13-01-2007   #5
Go on the Fiats!
 
Steven's Avatar
Join Date: Sep 2003
Posts: 14,845
Thanks: 10
Trader Rating: 8
Steven has donated!
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

This car is fuel injected.
__________________
2015 Fiat Panda Pop
Steven is offline Reply With Quote Quote 
Old 13-01-2007   #6
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Quote Originally Posted by Steve View Post
This car is fuel injected.
Just a joke with crabbo mate
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T14086 is offline Reply With Quote Quote 
Old 13-01-2007   #7
Join Date: Jun 2006
Posts: 788
Thanks: 48
Trader Rating: 0
reddy4bed has donated!
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Low fuel delivery i.e. fuel pump sounds most likely, also cambelt jumped a notch is worth a check out.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

reddy4bed is offline Reply With Quote Quote 
Old 13-01-2007   #8
Join Date: Aug 2003
Location: Essex/Suffolk border
Posts: 82,443
Thanks: 1458
Trader Rating: 10
dave has donated!
dave is an official FF Advertiser
dave is an honorary friend of the forum :)
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

the coil is fine! might be the other coil then
__________________
dave is offline Reply With Quote Quote 
Old 13-01-2007   #9
Burninator of threads!
 
faster4_tec's Avatar
Join Date: Oct 2004
Location: Sunderland and LakeDistri
Posts: 4,242
Thanks: 9
Trader Rating: 0
faster4_tec has donated!
Mongolia 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

yup, there are two coils

fuel pumps on the 75's have been known to do this. source one from a breakers yard, pref with less than 50k on it, should be fine, has to be a 75 though, any year and shape any colour, just be a 75.

also could have a major vacuum leak, but I would have hoped they would have heard that
__________________
Volvo for Life
faster4_tec is offline Reply With Quote Quote 
Old 13-01-2007   #10
Join Date: Aug 2006
Location: highlands
Posts: 2,523
Thanks: 113
Trader Rating: 0
United Kingdom 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

try a new lambna sensor on exhaust down pipe. sounds very familiar 2 me
i had sim, prob, some time back. took it 2 fiat garage, they put it on computor
nothing showed up, by the way runing like abag of bolts. turns out 2 be
sensor on exhaust right enough.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jimboy is offline Reply With Quote Quote 
Old 14-01-2007   #11
Join Date: Nov 2006
Posts: 155
Thanks: 0
Trader Rating: 0
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Quote Originally Posted by jimboy View Post
try a new lambna sensor on exhaust down pipe. sounds very familiar 2 me
i had sim, prob, some time back. took it 2 fiat garage, they put it on computor
nothing showed up, by the way runing like abag of bolts. turns out 2 be
sensor on exhaust right enough.
the other possibilty is spark plug leads if they havent been changed already
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

sps is offline Reply With Quote Quote 
Old 19-01-2007   #12
Join Date: Dec 2006
Posts: 5
Thanks: 0
Trader Rating: 0
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

problem found, it is the fuel pump, it wasn't fitted properly
it looks like it has been changed (badly) IT WASNT EVEN SCREWED BACK IN!!!! i think i should go get anouther one from somewhere thanks for the help
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

simp0388 is offline Reply With Quote Quote 
Old 20-01-2007   #13
Burninator of threads!
 
faster4_tec's Avatar
Join Date: Oct 2004
Location: Sunderland and LakeDistri
Posts: 4,242
Thanks: 9
Trader Rating: 0
faster4_tec has donated!
Mongolia 
Re: major problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

if the mountings have been damaged then YES,


otherwise petrol will slosh out into the car when you go round corners and speedbumps.

and if you roll it you'll be swimming in 47litres+ of petrol. which ain't clever
__________________
Volvo for Life
faster4_tec is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump