Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 24-10-2006   #1
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
engine not running right.

Hi, im looking for some help...

I have a Punto 1.1 (1997) thats done about 48000 miles, when i got in the car yesterday and started it up it started fine but the engine sounded rough. When i accelerate there is now power just a rough feeling throuout the car. The exhaust sounds like its put putting.

Ive changed the spark plugs and HT leads also done an oil change (about 500 miles ago).

When checking the oil and coolant levels last nite tho i noticed that both levels have dropped (in 2 weeks) quite a bit.

Also i notice a small amount of oil on the engine under the air box where the engine splits in too (sorry dont know what its called).

Is it the oil thats causing the problem or do i have a problem elsewhere??

Thanks for any help.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #2
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: engine not running right.

Sounds like the head gasket. This is quite common on the 1.1's and the 1.2's

Approx 250 to fix.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 24-10-2006   #3
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
Re: engine not running right.

250...???

That means i will have spent more on repairs than the i spent buying the car,
my m8 did say head gasket i just wanted to check.

Time to buy a new car i think!!

Thanks for your help anyway.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #4
Join Date: Oct 2006
Location: Scotland
Posts: 1,593
Thanks: 6
Trader Rating: 0
Punto.Power has donated!
United Kingdom 
Re: engine not running right.

Quote Quote:
Also i notice a small amount of oil on the engine under the air box where the engine splits in too (sorry dont know what its called).
That will be the rocker cover gasket and oil is leaking from it..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Punto.Power is offline Reply With Quote Quote 
Old 24-10-2006   #5
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: engine not running right.

Quote Originally Posted by fus1on
250...???

That means i will have spent more on repairs than the i spent buying the car,
my m8 did say head gasket i just wanted to check.

Time to buy a new car i think!!

Thanks for your help anyway.
I doubt you will by anything more reliable for less than 250. In my experience 55's are pretty reliable when they are running right.

Once you get the head gasket replaced keep the coolant topped up and keep the revs down for the first 2 miles and it will never happen again.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 24-10-2006   #6
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
Re: engine not running right.

Quote Originally Posted by Ransoman
I doubt you will by anything more reliable for less than 250. In my experience 55's are pretty reliable when they are running right.
Its had a new gear box at 35000 miles (400 cost), new exhaust 2 months ago, suspension needs replacing, fuel economy is awful to.
So i dont think i got one that runs right lol.

So would the rocker cover leak cause the problems i described?

Thanks again.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #7
Join Date: Oct 2006
Location: Scotland
Posts: 1,593
Thanks: 6
Trader Rating: 0
Punto.Power has donated!
United Kingdom 
Re: engine not running right.

Quote Quote:
So would the rocker cover leak cause the problems i described?
No it wouldint mines is the same just the gasket needs replaceing on the rocker cover..

Any water comeing out of the exhaust,mayo on the oil cap,oil in the water..?

Does this happen when you just start the car or once it warms up..? How noticeible is it in gears does it run better when in 4th and 5th or just the same..? Could maybe be the lambda sensor in the exhaust also could be a coil or fuel pump... Do any lights come on the dash.. Ressetting the ECU might help by unpluggin the battery over night..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Punto.Power is offline Reply With Quote Quote 
Old 24-10-2006   #8
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
Re: engine not running right.

Quote Originally Posted by Punto.Power
Any water comeing out of the exhaust,mayo on the oil cap,oil in the water..?

Does this happen when you just start the car or once it warms up..? How noticeible is it in gears does it run better when in 4th and 5th or just the same..? Could maybe be the lambda sensor in the exhaust also could be a coil or fuel pump... Do any lights come on the dash.. Ressetting the ECU might help by unpluggin the battery over night..
I just found out my exhaust is blowing (its a new exhaust) and water is coming out of where it blows, there is no mayo on oil cap and no oil in water.
But this rough drive is in all gears warm or not, and no lights come on on dash.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #9
Join Date: Oct 2006
Location: Scotland
Posts: 1,593
Thanks: 6
Trader Rating: 0
Punto.Power has donated!
United Kingdom 
Re: engine not running right.

Seems like your head gasket has gone most likely or 2 seperate things a coil pack and heater matrix leak if its the last thing the coolent will be coming out bottom of heater in the car and there will be a fishy eggy smell. Also if you look at the breather pipe from the rocker cover to the airbox and its chocked solid with greasy stuff and also some around the top (inlet) side of the carb and if there is some traces of water too then looks like the gasket...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Punto.Power is offline Reply With Quote Quote 
Old 24-10-2006   #10
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
Re: engine not running right.

i didnt think of the smell, the last 2 or 3 days i been able to smell an eggy smell. Just didnt know what it was.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #11
Join Date: Oct 2006
Location: Scotland
Posts: 1,593
Thanks: 6
Trader Rating: 0
Punto.Power has donated!
United Kingdom 
Re: engine not running right.

Does the windows kind of steam up bad in wet weather.. ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Punto.Power is offline Reply With Quote Quote 
Old 24-10-2006   #12
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
Re: engine not running right.

Quote Originally Posted by Punto.Power
Does the windows kind of steam up bad in wet weather.. ?
yeah im always wiping them so i can see.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #13
Join Date: Oct 2006
Location: Scotland
Posts: 1,593
Thanks: 6
Trader Rating: 0
Punto.Power has donated!
United Kingdom 
Re: engine not running right.

Specialy the drivers window will be misty have you checked for any coolant in the foot wells etc.. The whole dash has to come out if it is the heater matrix it also makes the car run rough and no power but heater matrix may leak onto the ECU immobilising the car so i would get that checked out..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Punto.Power is offline Reply With Quote Quote 
Old 24-10-2006   #14
Join Date: Oct 2006
Posts: 9
Thanks: 0
Trader Rating: 0
Re: engine not running right.

no ive not had any coolant in the foot wells. and its the winscreen thats the worst, drivers side window isnt too bad.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fus1on is offline Reply With Quote Quote 
Old 24-10-2006   #15
Join Date: Oct 2006
Location: Scotland
Posts: 1,593
Thanks: 6
Trader Rating: 0
Punto.Power has donated!
United Kingdom 
Re: engine not running right.

If you find out (IF) it is the heater matrix sounds like it is though could try a bottle of barsleak its worth a go. make sure you have your heater set to hot so the barsleak will enter the matrix that might fix the leak.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Punto.Power is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Uno 999 FIRE ie erratic idle on warm up (Bosch SPI) darren_hill Uno 12 07-11-2016 21:45
(T) Poor running and intermittent Engine management light Desmo Punto (Mk2/2b) 4 13-10-2005 14:40
engine conversion latch7 Newbie Central 6 26-09-2005 10:58
(T) engine swopped now running rough bluesmoke Punto (Mk2/2b) 3 09-09-2005 20:55
(T) oil sensor failure / engine disaster Heather's Stilo Stilo 24 07-05-2005 00:16