Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 01-09-2006   #1
Join Date: Aug 2006
Location: ggdf
Posts: 13
Thanks: 0
Trader Rating: 0
Bhutan 
Temperature sender or Thermostat

HI,
I have a mk2 punto 1.2 8v. After getting it back from MOT I noticed that the temperature gauge was on red (its never went past half way before). Ive checked for coolant leeks there is none. When the engine is started from cold it goes straight to to full (actually its always on full no mater what temperature the engine is) it goes back down when the engine is off, so i no the gauge aint sticking. The heaters work fine and the fan still kicks in, and there is no stalling or backfiring problems.I think it may be the temperature sender or thermostat anybody got any ideas which one it could be?

Thanx in advance
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mr_craig is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) 82 degree thermostat, keeps the car cooler! J333EVO Cinquecento / Seicento 136 16-04-2009 19:36
(T) Temperature Gauge issues arc Cinquecento / Seicento 35 29-07-2007 02:15
(G) Changing/Testing Thermostat lightweightmick Panda (Classic) 10 20-11-2005 00:11
(T) 55/60 temperature sender units - help needed! arc Punto (Mk2/2b) 2 10-03-2005 17:24
(T) Injector Warning Light / Temp Gauge Probs chuck Bravo / Brava 20 29-10-2004 01:06