Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 14-08-2006   #1
Join Date: Aug 2006
Posts: 2
Thanks: 0
Trader Rating: 0
Idle going berserk

Many of you have experienced the same problem as my son's Punto 55, P-reg. When hot, idle starts to surge then opens right up after 30 secs. Reset by blipping throttle. Fiat chap said it was the temperature sensor which he changed to no effect. Problem still there. Looks like idle control stepper motor.

The only person who seems happy that they have overcome this is by disabling this stepper motor. Does anyone know if this has ramifications or do they know some other way of getting to grips with this? would appreciate hearing from anyone with a solution to this problem which seems to be a Fiat feature??

Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bill Wilson is offline Reply With Quote Quote 
Old 17-08-2006   #2
Join Date: Aug 2006
Location: highlands
Posts: 2,536
Thanks: 113
Trader Rating: 0
United Kingdom 
Re: Idle going berserk

i had the very same prob some way back. my mech/mate told me to take stepper motor out[easy to do small star sockets] then spray the thing with wd40 .reasemle. worked fr me.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jimboy is offline Reply With Quote Quote 
Old 19-08-2006   #3
Join Date: Aug 2006
Posts: 2
Thanks: 0
Trader Rating: 0
Re: Idle going berserk

Many thanks! I am still hoping that its an electrical connection and suspect the lambda oxygen sensor connector which dangles in the front of the engine connector box. I fiddled with it briefly the other day and the fault was reportedly much improved. I have just had it apart and put it to together, it may not have been fully home and obviously subject to a lot of heat and vibration.
Taking the idle stepper off sounds to be a last resort due to the locking stuff on the screws. Time will tell
Thanks anyway
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bill Wilson is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Bravo 1.2 idle probs bikemad68 Bravo / Brava 10 25-07-2006 09:13
(T) 1.1 i.e. timing belt/cambelt and poor mixture (idle fault) andre79ge Uno 7 12-04-2005 16:36
(G) UNO 1.1 i.e. idle problems and iar leacks andre79ge Uno 7 21-11-2004 01:10
(T) 1.8 MW : weird idle behaviour chestnut Stilo 14 18-11-2004 20:16
(T) [Tipo 1.6 ie 94] Injection light and idle Malex Tipo (Classic) 1 28-07-2004 21:18