Register Login
endrop - for all your online needs
Reply
 
Thread Tools Search this Thread
Old 16-04-2018   #1
Join Date: Aug 2014
Posts: 417
Thanks: 25
Trader Rating: 0
United Kingdom 
Exclamation car radio aftermarket not working?

hi, i just purchased a pioneer car radio for "second hand". however i am experiencing some problem there is no power to the radio after fitting it.

when i remove the new radio and reinstall the old one "fiat punto radio" it works?

ive checked the fuse on the new radio and the fuse is fine.?

any ideas.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

BravoCity is offline Reply With Quote Quote 
Old 16-04-2018   #2
No strings on me
 
Eklipze3k's Avatar
Join Date: Nov 2007
Location: Huddersfield
Posts: 15,321
Thanks: 690
Trader Rating: 0
Eklipze3k has donated!
United Kingdom 
Re: car radio aftermarket not working?

First thing I'd do is test the 'new' unit in another vehicle, just to be sure that it does actually work.
If it does, then it may be that the vehicle wiring needs some adjustment in order to correctly power the unit, this is usually accomplished through the use of a separate wiring harness. So it should be vehicle wiring -> wiring harness -> headunit connectors.
__________________
Eklipze3k is offline Reply With Quote Quote 
Old 16-04-2018   #3
Join Date: Aug 2013
Posts: 452
Thanks: 33
Trader Rating: 0
nitramtpr has donated!
United Kingdom 
Re: car radio aftermarket not working?

Did you get a harness for fitting the pioneer into the Punto? You should have a short harness that plugs into the car and then the Pioneer will plug into that, you'll also need to wire in a permanent positive feed from the cigarette socket or something similar.
Check out the guides:

https://www.fiatforum.com/punto-mk2-...-not-mk2b.html

https://www.fiatforum.com/punto-mk2-...ring-help.html
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nitramtpr is offline Reply With Quote Quote 
Old 16-04-2018   #4
No strings on me
 
Eklipze3k's Avatar
Join Date: Nov 2007
Location: Huddersfield
Posts: 15,321
Thanks: 690
Trader Rating: 0
Eklipze3k has donated!
United Kingdom 
Re: car radio aftermarket not working?

Quote Originally Posted by nitramtpr View Post
... you'll also need to wire in a permanent positive feed from the cigarette socket or something similar.
Switched, the feed from the stereo wiring loom is already permanent.
__________________
Eklipze3k is offline Reply With Quote Quote 
Old 16-04-2018   #5
Join Date: Aug 2013
Posts: 452
Thanks: 33
Trader Rating: 0
nitramtpr has donated!
United Kingdom 
Re: car radio aftermarket not working?

Quote Originally Posted by Eklipze3k View Post
Switched, the feed from the stereo wiring loom is already permanent.
Ah yes of course you are quite right.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nitramtpr is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Aftermarket car radio Raymster Punto (Mk2/2b) 9 18-12-2017 01:20
What is the best aftermarket radio? Help liamr19 I.C.E 5 29-10-2013 19:46
B&M with aftermarket radio - USB not working rockambole Blue and Me 0 24-06-2013 15:12
(T) Aftermarket cd player not working! icysniper Punto (Mk2/2b) 4 25-08-2012 10:46
(T) Aftermarket CD player not working verlindel Punto (Mk2/2b) 0 05-03-2011 13:21