Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 09-04-2014   #1
Join Date: Apr 2014
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Question Wacky MkII electrical problem...

Hello All,

I have a bit of a puzzle with my 2001 Punto MkII, it goes like this;

The horn stopped working a few days ago, but was quickly fixed by just taking apart from spade clip connection on the -ve terminal and putting it back on. Sorted.

The next event may or may not be related.

A day later I jump in the car (it's raining) put the windscreen wipers on- they are sluggish. Lights are turned on at the stalk = rear windscreen wiper turns itself on. On later inspection the next morning the following happens;

(All systems off) then....

Hazards on = Rear windscreen Wiper turns On itself ( from now on abbrv to RWO)
Indicator on (left and right) = RWO
Front wipers on (& sluggish) = RWO
Sidelights on = all ok
Headlights on = RWO and no lights actually turn on.

All sorts of issues here as you can see. The battery is good, alternator charging fine, no fuses blown or bulbs out. Indicator stalks are working incrementally as they should do. All rear lights seem to be working fine but the front lights are getting confused - the sidelights are blinking (dimly) with the indicators. No headlights or Full beam lights at all.

So far I have;
-checked all fuses
-tested 2 earths on engine below battery (+ve battery terminal to earth reads around 12v) I think I've done that correctly.

Help?!

Regards,

Will

Long time reader, first time poster.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

farmerwill09 is offline Reply With Quote Quote 
Old 09-04-2014   #2
Busy rebuilding pand'a
 
oldhammer's Avatar
Join Date: Oct 2012
Location: manchester'ish'
Posts: 5,048
Thanks: 437
Trader Rating: 0
oldhammer has donated!
United Kingdom 
Re: Wacky MkII electrical problem...

Faulty stalks?

on the later' puntos the indicator stalk and wiper stalk are married up
as a full comm's units, so if one short's it can feed back,

stuff like the Flashdash with added silicone is normaly the killer of these.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

oldhammer is offline Reply With Quote Quote 
Old 09-04-2014   #3
Join Date: Apr 2008
Posts: 16,587
Thanks: 911
Trader Rating: 0
Ziggy122 has donated!
Eggs Champion, Fruit Pairs Champion
United Kingdom 
Re: Wacky MkII electrical problem...

because cleaning earths cheap - easy and quick todo

I've had a quick sckower over the wiring diagrams
Lights and wipers use 2 earthing points
EP1 - Gearbox
EP6 - Boot Earth

Since you said you've done gearbox to body one - thats obvs not the problem
Next i'd try the boot one - Passenger side, under the carpet on the back of the boot

Id be looking to make sure there is no water in there either.....

ziggy
__________________
!!WANTED!! 3dr Mk2 Punto Roof Bars !!WANTED!!

Meet Bumble-Bee


Ziggy122 is offline Reply With Quote Quote 
Old 09-04-2014   #4
Join Date: Apr 2014
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Wacky MkII electrical problem...

Hello,

Firstly thanks for the replies.

Update:

So as you so rightly pointed out - cleaning the earths are free so I did that on the earth point on the gearbox and the in line earth below the battery box. Box were in pretty good shape. The earth in the boot (passenger side and on the tailgate area) looked as good as new - no water or hint of corrosion.

That said are we looking at an earth fault somewhere else or the stalks (didn't know they were connected). With headlights on I'm getting 11v on the back of the bulb but they aren't coming on - filament is intact.

Thanks in advance for the help - all invaluable.

Will
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

farmerwill09 is offline Reply With Quote Quote 
Old 09-04-2014   #5
Join Date: Nov 2005
Location: Wexford
Posts: 3,011
Thanks: 217
Trader Rating: 0
Brendan W has donated!
Ireland 
Re: Wacky MkII electrical problem...

I would check the black earth wire in the plugs to the rear light clusters. Indicators draw a relatively large amount of current and if it can't find a good earth it will switch other things on by the back door, usually the other rear lights - the so called 'disco effect'
__________________
2001 1.2 8v
Brendan W is offline Reply With Quote Quote 
Old 09-04-2014   #6
Join Date: Apr 2014
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Wacky MkII electrical problem...

Hi Brendan,

Thanks, it's the front lights really. The only issue at the back is the rear wiper that goes off when the hazards/headlights/front wiper is turned on. No disco effect at the back - all lights functioning as normal.

It's the front where there's an issue - headlights not on, sidelights (the tiny ones at the base of the cluster) on with indicators.

I would like to know if there's a common earth/relay/switches to all the above that are going crazy.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

farmerwill09 is offline Reply With Quote Quote 
Old 09-04-2014   #7
Join Date: Nov 2005
Location: Wexford
Posts: 3,011
Thanks: 217
Trader Rating: 0
Brendan W has donated!
Ireland 
Re: Wacky MkII electrical problem...

There is a earth in the right footwell shared by the hazard switch and the indicator multi function switch. The stalk internals can get dirty with age and can be recovered with a spray of contact cleaner. You might hear a buzzing in the stalk or feel a slight warming in some cases.
__________________
2001 1.2 8v
Brendan W is offline Reply With Quote Quote 
Old 09-04-2014   #8
Join Date: Apr 2014
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Wacky MkII electrical problem...

SUCCESS!

Well done all, cleaned with silicone spray and after a while she came back to life. I also now have clean earths all other the place & now a bit more about my Punto.

Many thanks to you guys, you are providing an invaluable service, I wonder how many thousands you've saved!

Until next time...

Will
Likes Brendan W liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

farmerwill09 is offline Reply With Quote Quote 
Old 09-04-2014   #9
Join Date: Nov 2005
Location: Wexford
Posts: 3,011
Thanks: 217
Trader Rating: 0
Brendan W has donated!
Ireland 
Re: Wacky MkII electrical problem...

Do you know which one you think it was?
If you have a meter try sticking one lead in the coolant and the other on the block. More than 300mV means the coolant has lost it's corrosion inhibitors - fresh coolant mine is about 90mV. Now try it with the motor running - if it goes up it means currents are getting back to earth the 'wrong' way and as well as wacky problems it will eat the coolant system from the inside if it climbs over 300mv. Pulling different fuses can help pinpoint the cct at fault.
Obviously you have to switch things on progressively to provoke it.
__________________
2001 1.2 8v

Last edited by Brendan W; 09-04-2014 at 20:59.
Brendan W is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Wacky Stilo Videos BLKC99 Stilo 41 12-10-2011 20:28
(T) MKII Sporting Sterring Problem Phillippa Punto (Mk2/2b) 1 06-06-2010 13:52
(T) Heater/blower problem, MkII Punto Cabrio ~Polly~ Punto (Mk1) 5 17-05-2009 18:19
(T) 01 MKII 1.2 sporting Engine temp gauge problem The North Face Punto (Mk2/2b) 3 26-01-2008 11:19
wacky washers richiejohn Leisure Lounge 19 27-07-2007 23:50