Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 20-09-2011   #1
Join Date: Sep 2011
Posts: 8
Thanks: 0
Trader Rating: 0
Ireland 
Cool No sound from my speakers

Help I recently bought a 2000 punto and i put in a bluetooth radio.
it worked fine but now I can hardly hear any sound even with the radio
on full blast and thats only from the right speaker.

Do I need to replace wiring or speakers?

__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

suzymag is offline Reply With Quote Quote 
Old 20-09-2011   #2
Join Date: Nov 2010
Location: North West Kent
Posts: 68
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: No sound from my speakers

Its highly likely that the electrical connector block on the back of the radio has come loose. Check that before anything else.

Unfortunately, it is also possable that the speaker coils may have been fried by the output of your new radio. The speakers in early Punto's are not all that. Did the sound quality from the speakers become muffled before they died all together?. If yes, the speakers have had it.
I replaced the rear speaker in my Punto with 4" speakers from Maplin Electonics for about 5. The front dash speakers were replaced with units salvaged from a local breakers yard.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Simples31 is offline Reply With Quote Quote 
Old 21-09-2011   #3
Join Date: Sep 2011
Posts: 8
Thanks: 0
Trader Rating: 0
Ireland 
Re: No sound from my speakers

Thanks, Ive checked the connector at the back and its fine, I looked at the speakers and they dont look great. The sound is only coming from the driver side speaker and it is muffled.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

suzymag is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound from car speakers - thompsop07 I.C.E 0 20-09-2009 16:53
No Sound Through Speakers (Stilo 1.2) redmond38 I.C.E 3 19-05-2009 17:47
Mono sound through both left and right speakers? jiggy I.C.E 5 25-02-2008 10:20
Expensive new speakers sound like s**te DotSPF I.C.E 5 17-08-2004 23:56
New speakers sound awful Trebor I.C.E 5 23-03-2004 17:49