Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 02-04-2009   #1
Join Date: Apr 2006
Posts: 237
Thanks: 19
Trader Rating: 0
United Kingdom 
Off side rear light not working

My offside near light packed up. I've checked the fuses, and they're fine, and I've checked the bulb and it's fine. As a complete novice, is there anything else I can do to check, or is it best just booking it into a garage and letting them deal with it?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

djedwardsmith is offline Reply With Quote Quote 
Old 02-04-2009   #2
Join Date: Dec 2008
Location: Sussex
Posts: 423
Thanks: 55
Trader Rating: 0
United Kingdom 
Re: Off side rear light not working

Hi, check the connections are clean & make good contact with the bulb when inserted, are the other lights working in that light cluster?.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

inki is offline Reply With Quote Quote 
Old 02-04-2009   #3
Join Date: Apr 2006
Posts: 237
Thanks: 19
Trader Rating: 0
United Kingdom 
Re: Off side rear light not working

Yeah, every bulb works bar the lop left (looking from behind). Tried different bulbs and that didn't solve it, the fuses were fine, so I have no idea what it could be. The connectors looked fine earlier, is there anything else in between the bulb and the battery that could have fried?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

djedwardsmith is offline Reply With Quote Quote 
Old 02-04-2009   #4
Join Date: Oct 2006
Location: Glasgow
Posts: 8,120
Thanks: 308
Trader Rating: 3
ycming has donated!
United Kingdom 
Re: Off side rear light not working

hmm possible check the rear earth see if that is rust by any chance

ming
__________________
Wanted : Nothing at the moment
ycming is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Citroen Relay - Oil Pressure Light not working! + Fans not working! aroughcircle Non-FIAT 0 05-08-2007 13:45
(T) Rear brake light not working badkilla Stilo 19 08-11-2006 01:00
(G) Passenger Side Rear Light!!! mase Cinquecento / Seicento 3 22-11-2004 13:00