Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools Search this Thread
Old 03-09-2007   #1
Join Date: Sep 2006
Posts: 57
Thanks: 0
Trader Rating: 0
Blaupunkt Nav Cd Not Working :(

i have just bought a punto sporting with the factory fitted blaupunkt sat nav, the sat nav cd came with the car it is a 1999 cd, but the head unit says it is incompatible, i think it is a compatible cd as it has the blaupunkt logo on it and is travel pilot, can anyone advise?

thanks

max.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

officina_crane is offline Reply With Quote Quote 
Old 03-09-2007   #2
Join Date: May 2006
Posts: 382
Thanks: 3
Trader Rating: 0
Poondash has donated!
United Kingdom 
Re: Blaupunkt Nav Cd Not Working :(

Their are a few different cds for blaupunkt sat navs the one you have should be the RNS3 version (for puntos).

Also sounds a bit silly but make sure your putting it in the Sat nav itself not the multi-changer.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Poondash is offline Reply With Quote Quote 
Old 04-09-2007   #3
Join Date: Sep 2006
Posts: 57
Thanks: 0
Trader Rating: 0
Re: Blaupunkt Nav Cd Not Working :(

ah thanks i'll look into which cd i have, doesnt have any case or anything so may take some hunting, yeah ive been putting it in the drive behind the head unit, the one where the face flips down, i think thats the sat nav one. cheers max.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

officina_crane is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) SatNav stopped working after 9.8 upgrade adystorr Stilo 11 21-08-2007 17:10
Citroen Relay - Oil Pressure Light not working! + Fans not working! aroughcircle Non-FIAT 0 05-08-2007 13:45