Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 1 Week Ago   #1
Join Date: Aug 2017
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Electrical fault P0490

Hi, I was hoping to get some help with an electrical fault/s on my Punto Evo 1.6 multijet.

Itís throwing up codes:
P0487 & P0490

Both generic codes I believe? Something to do with the egr valve circuit.

Iíve had the car checked out at a garage and initially he thought it was just a dodgy fuse, so that was replaced. The engine management light soon came back on. Not only do I have the engine management light too, but since this I have noticed that upon acceleration it hesitates and you hear almost a flutter afterwards? Maybe a turbo flutter.

I was hoping to be pointed in the right direction or if anyone has had a similar problem?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by CameronD1357; 1 Week Ago at 14:52.
CameronD1357 is offline Reply With Quote Quote 
Old 1 Week Ago   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 21,076
Thanks: 743
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Electrical fault P0490

It shouldnt be a secret..
I will use the forums excellent SEARCH for you..

https://www.fiatforum.com/bravo/4398...9=#post4179808


What sort of use does the vehicle get.. ?
Performing regens ok ??


Is the garage the same place that does its oil changes
Likes CameronD1357 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by varesecrazy; 1 Week Ago at 15:12.
varesecrazy is offline Reply With Quote Quote 
Old 1 Week Ago   #3
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 4,171
Thanks: 420
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Electrical fault P0490

Sounds like a EGR or MAP sensor (on back of inlet manifold) issue. First thing to do is take the MAP off and clean it with brake cleaner or similar. Don't poke anything down the hole or slots in the sensor, some have a temperature sensor there that can be damaged. Obviously you need to clear the fault code too.

If that does not work you need to clean or replace the EGR. Note that blanking or eleting the EGR is illegal and is an MOT failure.

Robert G8RPI.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 6 Days Ago   #4
Join Date: Aug 2017
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Quote Originally Posted by g8rpi View Post
Sounds like a EGR or MAP sensor (on back of inlet manifold) issue. First thing to do is take the MAP off and clean it with brake cleaner or similar. Don't poke anything down the hole or slots in the sensor, some have a temperature sensor there that can be damaged. Obviously you need to clear the fault code too.

If that does not work you need to clean or replace the EGR. Note that blanking or eleting the EGR is illegal and is an MOT failure.

Robert G8RPI.
Cheers dude, will give this a go!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CameronD1357 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Electrical fault.. rich40 Grande Punto 0 18-11-2017 23:48
electrical fault James FIAT Boo Archives 5 03-01-2008 15:47
(G) Electrical Fault Please Help HAve Tried Everything maranzano Punto (Mk2/2b) 2 05-04-2006 16:15
electrical fault help please!! Anonymous FIAT Boo Archives 1 03-11-2004 10:38
(G) electrical fault equinox83xx Panda (Classic) 6 08-02-2004 16:33