Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 3 Weeks Ago   #1
Join Date: Oct 2019
Posts: 1
Thanks: 0
Trader Rating: 0
Netherlands 
Brake lights do not work. Fuse 11 brakes every time I brake

Hello all,

I have a problem with my Punto Evo 1.3 M-jet from 2011. My brake lights wont turn on when I am braking. It happened a couple of times in the past. I found out that fuse 11 in the dashboard fuse box (INT supply for instrument panel, switch on brake pedal (N.O. contact), third brake light) was broken. So I replaced it and it worked fine. Then a month later it happened again right before MOT. I changed the fuse again and it worked fine for a week or so. Then one weekend I went to Germany and it broke again. The dashboard says that the Start/Stop system is not available and the triangle icon is lit up. Every time that this happens the dashboard wont work after I turn of the car. I have checked that tail lights wiring and that looks fine. Then I thought it could be the brake light switch. So I removed that and changed the fuse and when I brake nothing happens (naturally because the brake light witch is out). And when I press the brake light switch with my hand also nothing happens. The fuse is fine but the brakes do not turn on. But the strange thing is when I put the brake light switch back and press the brake pedal the fuse is overloaded again. I have no idea what could be wrong. Maybe the wiring of the brake light switch? Maybe something else? I have bought a new brake light switch and it will arrive tomorrow. I have no idea what to do. Have any of you had the same problem? Any help would be appreciated.

Sorry for the long read.

Thanks,
PuntoEvo92
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PuntoEvo92 is offline Reply With Quote Quote 
Old 3 Weeks Ago   #2
Join Date: Oct 2017
Location: West Yorkshire
Posts: 1,605
Thanks: 74
Trader Rating: 0
chris3234 has donated!
United Kingdom 
Re: Brake lights do not work. Fuse 11 brakes every time I brake

Probably damaged wiring to one of the brake lights
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

chris3234 is offline Reply With Quote Quote 
Old 3 Weeks Ago   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 20,406
Thanks: 723
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Brake lights do not work. Fuse 11 brakes every time I brake

Hatch wiring.. or water ingress.

Are we talking later style LED lamps?

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) The trailer brake lights work, but turn left or right lights not feifeilake2 Stilo 13 31-08-2017 15:16
(T) Brake lights only work sometimes. watermelonman Idea 2 27-02-2017 20:24
(T) Fuse keeps blowing for brake/reverse lights bluespiral Cinquecento / Seicento 6 08-05-2011 12:11
(T) Mk2 Air bag light all the time after removing brake fuse! paulm Punto (Mk2/2b) 4 26-05-2008 19:41
(T) Brake lights on all time ?? gordnil Cinquecento / Seicento 5 24-03-2004 04:40