Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 08-01-2019   #1
Join Date: Jul 2017
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Failed Evo MOT (Horn)

My Evo just failed it's MOT due to a faulty horn. It doesn't work when the wheel is in a natural position, but when the steering is turned the horn works. Any ideas what could be wrong? Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Graeme77 is offline Reply With Quote Quote 
Old 08-01-2019   #2
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 4,025
Thanks: 405
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Failed Evo MOT (Horn)

Hi,
That is probably the steering wheel "clock spring" connection module.Steering wheel off job


Robert G8RPI.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 08-01-2019   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 19,873
Thanks: 710
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Graeme77 View Post
My Evo just failed it's MOT due to a faulty horn. It doesn't work when the wheel is in a natural position, but when the steering is turned the horn works. Any ideas what could be wrong? Thanks.
Yes.. there is a contactor to keep the connection whilst the wheel turns..

Years ago I turned wheel upside down so dead spot was at the bottom..

Slightly different now with airbags.. but principle is the same

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by varesecrazy; 08-01-2019 at 22:16.
varesecrazy is offline Reply With Quote Quote 
Old 20-01-2019   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 19,873
Thanks: 710
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Graeme77 View Post
My Evo just failed it's MOT due to a faulty horn. It doesn't work when the wheel is in a natural position, but when the steering is turned the horn works. Any ideas what could be wrong? Thanks.
Any progress?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Failed Horn on 02 Punto!!!! Perky Punto Punto (Mk2/2b) 7 28-09-2012 21:36
(G) Failed Mot philmoore Punto (Mk2/2b) 7 24-12-2007 23:47
(G) MOT = Failed - Failed - Failed. fenton_jd Punto (Mk2/2b) 5 07-08-2006 21:38
(G) Failed MOT, failed suspension strut Scorg Bravo / Brava 10 04-08-2006 09:13
(G) MOT failed OZ Seicento Cinquecento / Seicento 9 26-04-2006 19:24