Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 3 Weeks Ago   #1
Join Date: Dec 2018
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
2010 fiat punto evo not starting



Hi i have a 2010 fiat punto evo active 1.4 the issue is it wont start.It cranks over but does'nt even attempt to start.I have noticed the mileage is flashing could this be something to do with it?

I have done a diagnostic on it and its showing up with no codes

Any ideas before i take it to a garage many thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

markybee is offline Reply With Quote Quote 
Old 3 Weeks Ago   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 18,136
Thanks: 641
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by markybee View Post

Hi i have a 2010 fiat punto evo active 1.4 the issue is it wont start.It cranks over but does'nt even attempt to start.I have noticed the mileage is flashing could this be something to do with it?

I have done a diagnostic on it and its showing up with no codes

Any ideas before i take it to a garage many thanks.
Hi.

It'll be basic electrics.. look in the FAQs at top of GRANDE section.. same car under the bonnet


Charlie 07 MJ : 2012 TA
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 3 Weeks Ago   #3
Join Date: Dec 2018
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 2010 fiat punto evo not starting

hi i cant seem to find this section? any help would be apprecited thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

markybee is offline Reply With Quote Quote 
Old 3 Weeks Ago   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 18,136
Thanks: 641
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: 2010 fiat punto evo not starting

Grande punto.

Then yellow boxes..at top of GP section.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 3 Weeks Ago   #5
Join Date: Dec 2018
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 2010 fiat punto evo not starting

hi,
i tink i found it electrical gremlins?but this only seems to be for random lights coming on and charging problems.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

markybee is offline Reply With Quote Quote 
Old 3 Weeks Ago   #6
Join Date: Apr 2011
Location: Near the M4
Posts: 18,136
Thanks: 641
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: 2010 fiat punto evo not starting

Bad earth cable is a common failing.

Do that test 1st.

Also check immobiliser light is coming on before key chip is being read.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 3 Weeks Ago   #7
Join Date: Dec 2018
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 2010 fiat punto evo not starting

Hi, i tried the earth cable trick with the jump leads no differnt,when u put the key in there does'nt seem to be any imobiliser light? i'm guessing this is the orange padlock light?i took the plastic ring off around the ignition and then it came on?but once ring put back on it did'nt? any ideas is this normal or should a light come on?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

markybee is offline Reply With Quote Quote 
Old 3 Weeks Ago   #8
Join Date: Apr 2011
Location: Near the M4
Posts: 18,136
Thanks: 641
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by markybee View Post
Hi, i tried the earth cable trick with the jump leads no differnt,when u put the key in there does'nt seem to be any imobiliser light? i'm guessing this is the orange padlock light?i took the plastic ring off around the ignition and then it came on?but once ring put back on it did'nt? any ideas is this normal or should a light come on?
Yes.. the padlock light.

Should be on if the keychip isnt in range.

Or for the selftest.


Im not sure if a fault with the immob is looged as P.... engine code

Or U.... body computer

C.... canbus is an option

I am thinking Canbus.. so will need something better than basic OBD.

HAVE you pulled battery power for a few hours..??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) 2010 Fiat Punto Evo GP Heater position knob snapped off :-( jen91 Punto Evo 2 14-01-2013 20:51
2010 Fiat Punto Evo GP 1.4 badgeman Auction Watch 0 29-05-2012 20:04