Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 25-11-2015   #1
Join Date: Mar 2015
Posts: 75
Thanks: 3
Trader Rating: 0
ses6jwg has donated!
United Kingdom 
1.4 Multiair turbo smoking

Does any body elses 1.4 multiair turbo smoke quite heavily when first started up? It's kind of a white/ grey whispey smoke that rises up rather than pluming.

It seems to go away when the car is warmed up, except when reversing when it chucks it out again?

I do have a TMC motorsport box fitted which has made it a bit worse.

I don't seem to be using much oil. Have only topped up slightly since I bought the car in March. I have had to top the coolant up slightly (it dropped from MAX to MIN level) which does concern me... I have a slight yellow film under the oil cap sometimes but the car is sat sometimes for a week without any use. The coolant looks the right colour. It also starts first time without any problems and doesn't misfire, MPG looks about right and power isn't down.

Is it worth getting the head tested?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ses6jwg is offline Reply With Quote Quote 
Old 25-11-2015   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 20,569
Thanks: 728
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by ses6jwg View Post
Does any body elses 1.4 multiair turbo smoke quite heavily when first started up? It's kind of a white/ grey whispey smoke that rises up rather than pluming.

It seems to go away when the car is warmed up, except when reversing when it chucks it out again?

I do have a TMC motorsport box fitted which has made it a bit worse.

I don't seem to be using much oil. Have only topped up slightly since I bought the car in March. I have had to top the coolant up slightly (it dropped from MAX to MIN level) which does concern me... I have a slight yellow film under the oil cap sometimes but the car is sat sometimes for a week without any use. The coolant looks the right colour. It also starts first time without any problems and doesn't misfire, MPG looks about right and power isn't down.

Is it worth getting the head tested?
Possibly..
I would remove the spark plugs looking to see if 1 is sooty/ oily.

Charlie .Oxford
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 26-11-2015   #3
Join Date: Mar 2015
Posts: 75
Thanks: 3
Trader Rating: 0
ses6jwg has donated!
United Kingdom 
Re: 1.4 Multiair turbo smoking








Taken tonight. Car has been sat unused since Saturday. Ambient temp 2-11 degrees c.

Started with no trouble. No smoke until I poked the accelerator. Then it smoked wispy smoke. Quite heavily until up to temp. Hand over exhaust got very wet. Liquid looked clear. Coolant looks the correct colour.

Will try and get a video
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by ses6jwg; 26-11-2015 at 19:12.
ses6jwg is offline Reply With Quote Quote 
Old 26-11-2015   #4
Join Date: Mar 2015
Posts: 75
Thanks: 3
Trader Rating: 0
ses6jwg has donated!
United Kingdom 
Re: 1.4 Multiair turbo smoking

Ok. So I went for a drive tonight. Ambient temp is about 10 degrees. Bit of smoking around town until up to temp. Nothing at motorway speeds.

Stopped to idle for a bit and no smoke out of exhaust at idle and temp stays middle. No fan kicking in.

Revved it a bit at idle when up to temp and no smoke.

I'm just going to monitor it and see how things go.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ses6jwg is offline Reply With Quote Quote 
Old 02-07-2018   #5
Join Date: Jul 2017
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.4 Multiair turbo smoking

Quote Originally Posted by ses6jwg View Post
Does any body elses 1.4 multiair turbo smoke quite heavily when first started up? It's kind of a white/ grey whispey smoke that rises up rather than pluming.

It seems to go away when the car is warmed up, except when reversing when it chucks it out again?

I do have a TMC motorsport box fitted which has made it a bit worse.

I don't seem to be using much oil. Have only topped up slightly since I bought the car in March. I have had to top the coolant up slightly (it dropped from MAX to MIN level) which does concern me... I have a slight yellow film under the oil cap sometimes but the car is sat sometimes for a week without any use. The coolant looks the right colour. It also starts first time without any problems and doesn't misfire, MPG looks about right and power isn't down.

Is it worth getting the head tested?
Did you ever get this sorted? My Evo started doing the same. Thanks Steve
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

May4943 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
1.4L MultiAir Turbo Specs Thippid Tech Talk 3 02-02-2015 18:19
(Tu) Multiair Turbo Power loss alex evo Punto Evo 8 25-10-2014 01:07
(G) Correct Oil For Multiair Turbo col-blue Punto Evo 8 02-07-2013 20:15
(G) 1.6 MJ or 1.4 turbo Multiair? The Free(welsh)man Punto Evo 4 06-01-2012 15:20
(T) Some 1,4 MultiAir Turbo data Sev Bravo 4 12-05-2010 22:21