Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools Search this Thread
Old 13-09-2021   #16
Join Date: Mar 2016
Posts: 7
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

Hi,

Code is "P0087", "Fuel rail / system pressure too low". Incidently I took the fuel cap off and tried to start it but no joy. Any thoughts?

Mick
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

rmn is offline Reply With Quote Quote 
Old 13-09-2021   #17
Join Date: May 2011
Location: Norfolk UK
Posts: 11,795
Thanks: 583
Blog Entries: 8
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

I’d be looking at the high pressure fuel pump if there is low rail pressure.
Common on many diesels but on the 1.3 pump seals are a common problem.

They are not hugely expensive on the 1.3 these days but could still set you back a few hundred.

The pump is on the back end of the front cam shaft above the gearbox. Looks a bit like a flux capacitor
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

AndyRKett is offline Reply With Quote Quote 
Old 13-09-2021   #18
Join Date: Mar 2016
Posts: 7
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

Yep,

tried that but no joy. Code reading is P0087 - "Fuel rail / system pressure too low". Any thoughts?

Mick
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

rmn is offline Reply With Quote Quote 
Old 13-09-2021   #19
Join Date: May 2011
Location: Norfolk UK
Posts: 11,795
Thanks: 583
Blog Entries: 8
Trader Rating: 0
United Kingdom 
Quote Originally Posted by rmn View Post
Yep,

tried that but no joy. Code reading is P0087 - "Fuel rail / system pressure too low". Any thoughts?

Mick
The code is reading fuel rail system pressure too low, most likely because of the failure of the high pressure fuel pump.

When you say “tried that” do you mean you’ve replace it !?
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

AndyRKett is offline Reply With Quote Quote 
Old 13-09-2021   #20
Join Date: Apr 2011
Location: Near the M4
Posts: 29,266
Thanks: 1155
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by rmn View Post
Yep,

tried that but no joy. Code reading is P0087 - "Fuel rail / system pressure too low". Any thoughts?

Mick
Chances are..

Pump is tired
Or
You have a Bleeding off problem
Or
You have low cranking speed

See what pressures you are currently achieving
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 14-09-2021   #21
Join Date: Oct 2016
Posts: 3,641
Thanks: 392
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

I dont know

It not as far as I can tell a common code on a fiat and this engine is over 15 years old

I found a few threads where this, that and other has been changed, then the threads have gone dead.

Examiner doesn't report this code as low fuel pressure ?

If you clear the code, does it come back.

Not even 100% its not caused by the long cranking ?

I am guessing and dont see an easy way to progress. Testing the fuel pressure with the injectors disconnected would be the way to go at a garage. This would instantly tell if either fuel pump were faulty.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

koalar is offline Reply With Quote Quote 
Old 14-09-2021   #22
Join Date: Mar 2016
Posts: 7
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

Oops, sorry, thought my post hadn't taken! No, I meant I'd tried the removing fuel cap in case a blocked valve.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

rmn is offline Reply With Quote Quote 
Old 14-09-2021   #23
Join Date: Nov 2020
Posts: 156
Thanks: 13
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

Have a look at running a injector bleed back test lots of how to's
on Utube if you have a bad injector the pump wont be able to
get the pressure high enough,
__________________




If you find a fix for your problem please let us know it will help others.
RalphM is offline Reply With Quote Quote 
Old 4 Weeks Ago   #24
Join Date: Sep 2009
Posts: 17,551
Thanks: 902
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

My 100HP did the refusal to start thing last summer after being laid off for weeks due to the Covid lockdown. Battery was charged everything ran as it should - engine spun over as it should but there was not the slightest attempt to start. MES refused to work which had me running around for days trying to fix the computer (see more later).

After checking fuel pump, coil, plugs, ignition switch and individually testing every fuse in the car, it suddenly started working and hasn't looked back. The one oddity was that OBD socket was dead - no power. I never found out why, but that's what was killing the car and why my MES had appeared to be faulty.

Check you have power at the OBD socket. AnyOBD tester will do. The issue is a faulty connection somewhere. Best of luck finding it but at least it's consistent so worst case an auto electrician will be able to find it.
Thanks varesecrazy thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DaveMcT is offline Reply With Quote Quote 
Old 5 Days Ago   #25
Join Date: Mar 2016
Posts: 7
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

Hi again!

Well, seemingly the local garage put it down to a relay (T10 I believe). Anyhow, that seemed to do the trick though they replaced fuel filter first on the off chance which majes sense. 4 weeks later though exactly the same happens. Slight falter when in top at about 50mph after a few miles and the engine light comes on. Makes it home by not stopping the engine and once home stop engine and it will then turn over but not fire - as before. Link up code reader and it's my friend P0087 with the punch line of "fuel rail / system pressure too low". On swopping the high beam relay (T02) and T10, which are identical 20A ones, the engine fired up!

I have a nasty feeling it will end up being the fuel pump!

See you all again soon with the next exciting installment .....
Thanks koalar thanked for this post
Likes koalar, varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

rmn is offline Reply With Quote Quote 
Old 5 Days Ago   #26
Join Date: Apr 2011
Location: Near the M4
Posts: 29,266
Thanks: 1155
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Cross 1.3 not starting

Did the tank pump still whirr ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 2 Days Ago   #27
Join Date: Sep 2009
Posts: 17,551
Thanks: 902
Trader Rating: 0
United Kingdom 
Re: Cross 1.3 not starting

Quote Originally Posted by rmn View Post
On swopping the high beam relay (T02) and T10, which are identical 20A ones, the engine fired up!
It just might be a bad connection in the fusebox that is affecting the power being delivered by the relay. Swapping them about being enough to improve the contact. See if you can close up the female contacts (within the fuse box) that take the relays.

This might also give some clues. Used pumps about £50 to £80 regulator £45.
https://www.ebay.co.uk/sch/i.html?_f...+pump&_sacat=0

Here's the pump seal kit. Worth a punt at £17.75, if it's all that's needed to refurb the pump.
https://www.ebay.co.uk/itm/162076517...AAAOSwKadXPgUO
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by DaveMcT; 2 Days Ago at 10:29.
DaveMcT is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Fiat 500 cross oil smell in cabin when starting from warm engine Terry Fisher 500X 8 19-08-2019 14:27
cross x bobanana Newbie Central 0 14-06-2015 13:14
Panda Cross Newbie (very cross) Ruth K Newbie Central 1 19-10-2013 23:39
(G) Panda Cross Discounts starting Geordie Amanda Panda 8 06-09-2008 12:07
what do you get when you cross... Dazza Leisure Lounge 15 29-01-2005 00:20