Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 1 Week Ago   #16
Join Date: Jan 2012
Location: East
Posts: 1,389
Thanks: 54
Trader Rating: 1
The Panda Nut has donated!
United Kingdom 
Re: Post Oil Change Running In

Have you checked the turbo waste-gate linkage. There has been some talk of premature failure resulting in limp home mode. If by chance it is this I think there may be a repair kit but a turbo specialist would be able to sort it without resulting to a new turbo. It sounds really annoying so I will keep my fingers crossed you get to the bottom of it without a heap of expense.
__________________
Noop now known as Nooplebe (i.e. in the way wherever he goes) 🐼
The Panda Nut is offline Reply With Quote Quote 
Old 1 Week Ago   #17
Join Date: Dec 2007
Location: Endmoor
Posts: 785
Thanks: 48
Trader Rating: 0
United Kingdom 
Re: Post Oil Change Running In

Car had oil change today, with brake fluid and wiper blades. Saving on main dealer prices of around 60 I'd have thought. Performance unaffected this time, car had done around 3700 miles in 6 months. May be fine now but it's not journey home where it doesn't like something. Will be 24-36 hours time when I know.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Al D is offline Reply With Quote Quote 
Old 1 Week Ago   #18
Join Date: Dec 2007
Location: Endmoor
Posts: 785
Thanks: 48
Trader Rating: 0
United Kingdom 
Re: Post Oil Change Running In

@varesecrazy you were right by looks. Car been fine so oil similar quality to what got drained out presumably.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Al D is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Post ignition rough running atom0007 Punto (Mk2/2b) 1 28-12-2015 10:44
(T) Engine Oil change indicator wont stop after oil change! arbervehbi Croma 8 17-09-2015 20:34
(T) 1.2 8v Post timing belt change series2a Palio 5 08-10-2010 16:33
(T) Post Camshaft change problems dvewls Bravo / Brava 9 17-09-2010 18:16
(T) Running in oil change stinkyparp 500 7 15-01-2010 07:38