Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 17-09-2016   #1
Join Date: Sep 2016
Posts: 13
Thanks: 0
Trader Rating: 0
United Kingdom 
1964 Fiat 600 D issues

I've always been a Fiat fan since may parents bought our first Fiat 600D back in 1965. I've had Fiat/Alfa Romeo cars ever since.

I have a slight issue with my Fiat 600 D. The engine stops/dies whilst on the move. The ignition light lits up. If still moving, I tried to start the car by pressing the clutch and releasing it whilst still in gear (akin to push starting). It would not start. When the car finally stops, I the car started after about three goes using the ignition key. The drives normally again.

The following day it happened again. The engine just stops whilst driving. Pushed the car to the side. The car would not start. It had no issues turning. After waiting for about 30 minutes or so, it started, and everything seems normal again.

Could it be the fuel pump and /or the coil? Any assistance you can provide will be highly appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Amateb953 is offline Reply With Quote Quote 
Old 19-10-2016   #2
Join Date: May 2015
Posts: 71
Thanks: 1
Trader Rating: 0
Egypt 
Re: 1964 Fiat 600 D issues

hey my friend I'm not an expert but If I were you I would suspect some of the following things mate, engine overheating, low oil pressure, bad spark timing, bad supply of fuel, or maybe bad compression too,so let's eliminate the suspects and see what's wrong,

First of all check the coolant (antifreeze or water) temperature and pressure in your engine and check the engine oil level too,pressure and grade, check for any leaks under the car
Second thing is to check with the mechanic the following things (ignition system, fuel supply system)
Third step is to do a compression test for your engine (maybe the car can't breathe too)

but that sounds alot, so just see step number 1 for now and if everything seems normal proceed with step number 2

good luck mate
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Mando; 19-10-2016 at 14:09.
Mando is offline Reply With Quote Quote 
Old 23-10-2016   #3
Join Date: May 2015
Location: Canberra
Posts: 624
Thanks: 19
Trader Rating: 0
Australia 
My Fiat 500 was doing the same thing and from memory I changed the condenser and that fixed it. ( it was 18 months ago)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

1500500 is offline Reply With Quote Quote 
Old 02-11-2016   #4
Join Date: Mar 2013
Location: Tamworth
Posts: 281
Thanks: 8
Trader Rating: 0
United Kingdom 
Re: 1964 Fiat 600 D issues

I would guess electrical or fuel.

Change condenser, points as well if youve got any.
fuel pressure next - check output from pump is healthy
check carb isnt blocked with crud (you will need to strip it to a degree to find out)
I've had a 600D I used to do production car trialling in - sadly no photos. They are rare in the UK, but look what I found in a barn in Menorcal last year - there were 3 of them
Attached Thumbnails
Click image for larger version

Name:	seat 600 1.jpg
Views:	12
Size:	94.9 KB
ID:	172999   Click image for larger version

Name:	seat 600 2.jpg
Views:	10
Size:	66.3 KB
ID:	173000  

Click image for larger version

Name:	seat 600 3.jpg
Views:	11
Size:	94.3 KB
ID:	173001   Click image for larger version

Name:	seat 600 4.jpg
Views:	11
Size:	54.8 KB
ID:	173002  

Click image for larger version

Name:	seat 600 5.jpg
Views:	11
Size:	65.5 KB
ID:	173003  
Likes Mando liked this post
__________________
2003 Seicento sporting production car autotester
2005 Transit Connect LWB high roof
2007 Transit LWB 100hp dog grooming van
1965 Morris Minor Saloon
Metalguru3 is offline Reply With Quote Quote 
Old 08-11-2016   #5
Join Date: Apr 2011
Location: Near the M4
Posts: 20,139
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: 1964 Fiat 600 D issues

Quote Originally Posted by Amateb953 View Post
I've always been a Fiat fan since may parents bought our first Fiat 600D back in 1965. I've had Fiat/Alfa Romeo cars ever since.

I have a slight issue with my Fiat 600 D. The engine stops/dies whilst on the move. The ignition light lits up. If still moving, I tried to start the car by pressing the clutch and releasing it whilst still in gear (akin to push starting). It would not start. When the car finally stops, I the car started after about three goes using the ignition key. The drives normally again.

The following day it happened again. The engine just stops whilst driving. Pushed the car to the side. The car would not start. It had no issues turning. After waiting for about 30 minutes or so, it started, and everything seems normal again.

Could it be the fuel pump and /or the coil? Any assistance you can provide will be highly appreciated.
have you had any luck with this..?,

Charlie - Oxford
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 10-11-2016   #6
Join Date: May 2015
Posts: 71
Thanks: 1
Trader Rating: 0
Egypt 
Re: 1964 Fiat 600 D issues

Aspiration/Intake System:
another reason came to my mind, maybe too much air getting to the engine, making a bad/improper fuel & air mixture, creating what is called " lean fuel mix " which means very small amount of fuel burned which affects the operation and performance too, this is caused by a leak in the air intake system, the gasket or something

Fuel System:
check also the fuel route/track, the fuel container/tank (leak), the fuel pump (mechanical or electrical one) (faulty), the fuel lines (clogged), the carburetor (dirty or clogged)

Electrical System:
Alternator (faulty, putting the load on the battery), spark plugs, ignition coils or distributor (misfiring, firing at wrong times)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Mando; 10-11-2016 at 12:50.
Mando is offline Reply With Quote Quote 
Old 19-11-2016   #7
Join Date: Nov 2016
Posts: 6
Thanks: 0
Trader Rating: 0
Norway 
Re: 1964 Fiat 600 D issues

Hi Amateb953
Have you solved your problem? I have the same problem with my Jagst 770 (same car as 600D) I have checked timing, coolant, fuel filters, and replaced condenser, contact breaker and igniton wires, but still the same problem.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Milk is offline Reply With Quote Quote 
Old 20-11-2016   #8
Join Date: Nov 2016
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1964 Fiat 600 D issues

Quote Originally Posted by Amateb953 View Post
I've always been a Fiat fan since may parents bought our first Fiat 600D back in 1965. I've had Fiat/Alfa Romeo cars ever since.

I have a slight issue with my Fiat 600 D. The engine stops/dies whilst on the move. The ignition light lits up. If still moving, I tried to start the car by pressing the clutch and releasing it whilst still in gear (akin to push starting). It would not start. When the car finally stops, I the car started after about three goes using the ignition key. The drives normally again.

The following day it happened again. The engine just stops whilst driving. Pushed the car to the side. The car would not start. It had no issues turning. After waiting for about 30 minutes or so, it started, and everything seems normal again.

Could it be the fuel pump and /or the coil? Any assistance you can provide will be highly appreciated.
is the engine getting hot?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bizzyfiat600 is offline Reply With Quote Quote 
Old 23-11-2016   #9
Join Date: Sep 2016
Posts: 13
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1964 Fiat 600 D issues

It was not overheating, if that is what you mean.

Strangely, it hasn't happened again.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Amateb953 is offline Reply With Quote Quote 
Old 23-11-2016   #10
Join Date: Sep 2016
Posts: 13
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1964 Fiat 600 D issues

I just had a full service on mine (contact points, condenser etc.) when it happened. I mentioned it to the Fiat/Alfa Romeo specialist that serviced it. He states it could be the ignition coil. I didn't pursue the coil theory as it appears to be running well again.

I'll keep you posted it it happens again.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Amateb953 is offline Reply With Quote Quote 
Old 23-11-2016   #11
Join Date: Sep 2016
Posts: 13
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1964 Fiat 600 D issues

I checked the receipt. The mechanic also strip the carb. and used a carb repair kit.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Amateb953 is offline Reply With Quote Quote 
Old 30-11-2016   #12
Join Date: Nov 2012
Location: NSW, Australia
Posts: 70
Thanks: 2
Trader Rating: 0
Australia 
Re: 1964 Fiat 600 D issues

Check and clean the "King lead", the HT lead that goes to the coil. There can be some corrosion there that causes these symptoms. If the engine fails suddenly it's usually electrical. Splutters and jerks and fails probably fuel.
__________________
Porsche 928s, Mercedes E280, Mazda MX5 track car, 1970 Fiat 850 coupe track car.
Ramona is offline Reply With Quote Quote 
Old 30-11-2016   #13
Join Date: Apr 2011
Location: Near the M4
Posts: 20,139
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: 1964 Fiat 600 D issues

Quote Originally Posted by Milk View Post
Hi Amateb953
Have you solved your problem? I have the same problem with my Jagst 770 (same car as 600D) I have checked timing, coolant, fuel filters, and replaced condenser, contact breaker and igniton wires, but still the same problem.

hi,

is it getting HOT,
or just stuttering / jerking..??

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 30-11-2016   #14
Join Date: Nov 2016
Posts: 6
Thanks: 0
Trader Rating: 0
Norway 
Re: 1964 Fiat 600 D issues

Hi

After 20-30 min the temperature of the engine head reach approximately 70 deg. celsius, and the engine dies. I can still spin the engine on the starter, but the engine will not start. After 5 min or so, the engine start and runs for some minutes, before it dies again...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Milk is offline Reply With Quote Quote 
Old 30-11-2016   #15
Join Date: Apr 2011
Location: Near the M4
Posts: 20,139
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: 1964 Fiat 600 D issues

Quote Originally Posted by Milk View Post
Hi

After 20-30 min the temperature of the engine head reach approximately 70 deg. celsius, and the engine dies. I can still spin the engine on the starter, but the engine will not start. After 5 min or so, the engine start and runs for some minutes, before it dies again...
Hi,
have you tested for a spark when it's HOT and dies..??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
1964 Fiat 600 D issues Amateb953 Newbie Central 0 17-09-2016 13:07
(T) 1964 Fiat 600 vent window help needed. TeamEvil Other Fiats 0 19-03-2010 15:07