Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 4 Weeks Ago   #1
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Please Help

Hi there

Seems like no one responded to my previous thread, I am still having problems with my Fiat uno. 3 weeks back my car broke a timing belt after replacement the car was no longer in good state, it started to act up high and rough idling cutting every minute I slow down, I replaced every necessary part I thought it could be the cause of the problem from changing carburetors, buying a new ECU/Module, distributor, spark plugs still to no avail. No one responded to my previous thread please help am stuck the car however it's starting fine when driving locally it would cut everytime I slow down or stop. Yesterday I decided to go on a high way I took 200km run the car was running perfectly with 100 to 120km but a bit lazy on uphills as the carburetor wouldn't be adjusted however it drove well and back home. This morning I went to see a mech and he suggested I do the engine rework and I think that's insane, how can the car still be running when it needs the engine overhaul. When you listening to the car while it's idling the rpm is going high and low as if someone is stepping on the throttle. Please help
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Old 4 Weeks Ago   #2
Join Date: Aug 2006
Location: highlands
Posts: 2,492
Thanks: 109
Trader Rating: 0
United Kingdom 
Re: Please Help

No idea what model you have or if it's a non interference. If your car was running fine before the belt snapped obviously you must have done something wrong when replacing the belt, whether it's timing or if the engine is damaged in some way it's pure guess work on my behalf. I would go over everything you've done, it may be something simple. If you have a friend who's mechanically minded, two heads are better than one as they say. Best of luck.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jimboy is offline Reply With Quote Quote 
Old 4 Weeks Ago   #3
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Re: Please Help

It's a fiat Uno fire 1100 8v,its highly impossible that it could bend the valves when it snaps the timing belt, the timing is right and everything in order I don't know what to look for anymore. I downloaded the Haynes manual I can't seem to get a direct answer.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Old 4 Weeks Ago   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 19,940
Thanks: 710
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Please Help

Starting well??

Is this electric fuel pump..or from the cam?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 4 Weeks Ago   #5
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Re: Please Help

Yes it does start well I think it's an electric the fuel pipe is near the distributor
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Old 4 Weeks Ago   #6
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Here's the pic of the fuel pump
Attached Thumbnails
Click image for larger version

Name:	IMG_20190818_154517.jpg
Views:	3
Size:	2.94 MB
ID:	202340  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Old 4 Weeks Ago   #7
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Re: Please Help

Sometimes I need to give it a little bit of a throttle for it to start but the idling is too bad😏 worst than that of a tractor or a diesel car where I go it throws attention👀
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Old 4 Weeks Ago   #8
Join Date: Apr 2011
Location: Near the M4
Posts: 19,940
Thanks: 710
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by tumi1986 View Post
Here's the pic of the fuel pump
Position is common to the mechanical type.


A vacuum leak could cause poor running.

Look for info in the
'Classic panda' section

Newbie.. not many look in there for technical assistance.

And your ENGINE tech finished in the UK

@1990..

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 3 Weeks Ago   #9
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Re: Please Help

I think I found the culprit at last, yesterday I've been listening carefully to the car while idling, something ave been missing all along the engine is knocking at the top I think it's the tappets I will dismantle the top over the weekend for valve clearance, I think it lost compression that day it snapped the timing belt because the cams where jammed, when you crank the engine they wouldn't turn at all the bottom pulley bolt was lose as well I'll be looking into it over the weekend as and post back the reply here.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Old 3 Weeks Ago   #10
Join Date: Jan 2016
Posts: 49
Thanks: 0
Trader Rating: 0
South Africa 
Re: Please Help

I think I found the culprit at last, yesterday I've been listening carefully to the car while idling, something ave been missing all along the engine is knocking at the top and its smoking on idle and on throttle the smoke is kinda blueish and black I just can't tell cos before it was white smoke, I think it's the tappets I will dismantle the top over the weekend for valve clearance, I think it lost compression that day it snapped the timing belt because the cams where jammed, when you crank the engine they wouldn't turn at all the bottom pulley bolt was lose as well I'll be looking into it over the weekend as and post back the reply here.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

tumi1986 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump