Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 11-09-2018   #1
Join Date: Jul 2018
Posts: 3
Thanks: 0
Trader Rating: 0
South Africa 
Angry performance !!!!!!!!!1.2 8v

hi there .ok here it goes
i have 1.2 fiat strada 2007 model.only driver since new the bakkie was very nipy in towns and open roads did drive it 160kmph no problems.when she the 400000km on the clock still running good but top performance went down a bit
the i did the pistons rings bore and the head is done also still nothing better.what i did in since the problem

new pistons
rings
bore
valves'
throttle body cleaning
performance air filter

no difference i really have to push very hard to get 140kmph out of it and when driving 110kmph my fuel is 10l/100km,

so i did check she doesn't have obd2 only 2 pin plug next to ecu.

my question is how do i know its the lambda,airflow,or ecu that is my problem i need to sort her out.

what else maybe can be my probblem

thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jcdbosveld is offline Reply With Quote Quote 
Old 11-09-2018   #2
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,206
Thanks: 1138
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: performance !!!!!!!!!1.2 8v

How much did you have to take out of the bores to get them parallel?

D
__________________
rallycinq is offline Reply With Quote Quote 
Old 11-09-2018   #3
Join Date: Jul 2018
Posts: 3
Thanks: 0
Trader Rating: 0
South Africa 
Re: performance !!!!!!!!!1.2 8v

the engineering told me was like 20thou or so i sent the sub assemby to them d.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jcdbosveld is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Palio Performance phoenix93 Members Motors 4 09-09-2013 06:20
(T) performance bravachris Bravo / Brava 7 13-11-2008 14:01
(T) performance immsy Cinquecento / Seicento 5 08-11-2006 14:52
Performance problem since service- disconnected MAF sensor, no change in performance? Kristian FIAT Boo Archives 3 26-03-2006 21:24
Performance of a 1.2 Bill FIAT Boo Archives 6 12-01-2005 16:21