Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 17-03-2005   #1
Join Date: Feb 2005
Posts: 2
Thanks: 0
Trader Rating: 0
Brake Fault

Hi,
I own a 1.9JTD Multipla and am very happy with the car - it is now in its' final year of the manufacturer's 3 year warranty period.

Recently, on starting the car (from cold), after 10 secs driving, the brake pedal became inoperative - the pedal became hard and it seemed that there was no servo (hydraulic) assist. This cleared after a few (hairy) seconds. This fault repeated 2 days later in similar circumstance, weather conditions varied from fairly cold to warm.

I got the brakes checked at the Fiat / AC dealership. They couldn't find anything after a 'visual' inspection and a go on the MOT test. As such they not only charged me for this time, but I still have a somewhat intermittent fault with the brakes.

Anyone come across this before? - vehicle has only done 10K and seems the warranty doesn't cover for potential brake part change out as this is classed as normal wear and tear.
I am afraid that the garage wasn't too sympathetic and I was annoyed as this is not really a fault that you can live with.

thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nbuchana is offline Reply With Quote Quote 
Old 27-03-2005   #2
Join Date: Mar 2005
Posts: 3
Thanks: 0
Trader Rating: 0
France 
Re: Brake Fault

I have had exactly the same problem. The garage who sold the car to me insisted that it was me, and there was actually no problem at all! After speaking with another mechanic I was told it was probably a problem with the servo. I returned to the garage, the owner once more insisted it was okay, but a mechanic who worked for him uncoupled and reattached the air tube controlling the servo - perfect! I have had the problem once more after the last service, I made the same procedure - no probs. Hope it helps, it would be better if the garages owned up to problems in the first place!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

maxinfrance is offline Reply With Quote Quote 
Old 29-03-2005   #3
Join Date: Feb 2005
Posts: 2
Thanks: 0
Trader Rating: 0
Re: Brake Fault

Hi,
Thanks for the note.
I was beginning to think that no one had heard of this problem before. The dealership dont want to know!!!

I will check this out, when it happens again. Strange though, is it a leaking / faulty connection on the air line causing the loss of air pressure? Or something else?

Thanks again...................
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nbuchana is offline Reply With Quote Quote 
Old 29-03-2005   #4
Join Date: Mar 2005
Posts: 3
Thanks: 0
Trader Rating: 0
France 
Re: Brake Fault

Seems to be a fault with the connection working loose, as after disconnecting and reconnecting the line it's perfect. maybe a problem with dirt or grease getting in? If you disconnect the line you have exactly the same result. I'm sure the garage/dealers know about the fault.

Hope it helps
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

maxinfrance is offline Reply With Quote Quote 
Old 18-02-2009   #5
Join Date: Jan 2009
Posts: 27
Thanks: 0
Trader Rating: 0
Re: Brake Fault

I know this is an old thread but where do I find the brake servo and airline on a 2003 JTD?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DORSETVDUBSTER is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Cinq Sporting Electrical Problem - Brake lights/rear lights namb Cinquecento / Seicento 3 20-02-2005 17:00
(T) Another brake light problem cruisestoke Cinquecento / Seicento 2 01-10-2004 13:31
(T) Brake Light Switch Rich Stilo 5 24-07-2004 19:31
(T) Noisey brake pads stiloactive Stilo 4 08-11-2003 06:06