Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 13-06-2010   #1
Join Date: Jun 2010
Posts: 66
Thanks: 3
Trader Rating: 0
United Kingdom 
Question A real head scratcher!! Map Sensor or ECU fault??

Hi, can anyone help?? I recently bought a 2001 1.9TD ELX 105 JTD which required a new turbo. One was duly fitted but the car remained in limp mode with high revs. The fault code P0236 Boost Valve Pressure appeared. My mechanic spoke to Fiat who advised a new MAF sensor, this was duly replaced but the car still remained in limp mode with high revs. The mechanic then followed ALL of the advice given previously on this forum with regards to code clearance but the problem remains. He then transported the car to Fiat for diagnosis and incredibly they said they had no idea what the problem was but it MAY be a faulty ECU, faulty map sensor or faulty turbo.... My ex seems to feel the problem may lie with the MAP sensor. We fitted fiat part no. 46468682 (Bosch 0 281 002 215) which was a direct replacement of the one previously fitted but could possibly have been the wrong part in the first place!! Before I spend any more money on this car I would appreciate some advice on where to go next. It transpires there are TWO Map sensors which fit this car - The one currently fitted and Fiat part no. 46811235 (Bosch 0 281 002 510 or 552) The difference appears to be that one is a 186AXE1A and one is a 186AXB1A can anyone advise what the difference is in part terms. I can find no information about which of these relates to my car. Also would it be beneficial to get the ECU checked? The mileage on the car is only 61,000 and Fiat suggest this is a common fault, if I do need to go down this route I would really appreciate recommendations on reputable companies.
Many thanks in anticipation of help
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

millymoon is offline Reply With Quote Quote 
Old 16-10-2010   #2
Join Date: Apr 2006
Location: Lincolnshire
Posts: 106
Thanks: 11
Trader Rating: 0
robbie-rocket-pants has donated!
United Kingdom 
Re: A real head scratcher!! Map Sensor or ECU fault??

According to the website :
http://www.meat-doria.com/product_meat/82126

both MAPs can be fitted to the 110 JTD multipla, but only 46811235 appears for the 105 multipla.....but better check in case I missed it.
.
__________________
Think or thwim

Last edited by robbie-rocket-pants; 16-10-2010 at 14:00.
robbie-rocket-pants is offline Reply With Quote Quote 
Old 16-10-2010   #3
Join Date: May 2010
Posts: 171
Thanks: 16
Trader Rating: 0
United Kingdom 
Re: A real head scratcher!! Map Sensor or ECU fault??

the 105 jtd is a 186AXB1A, you should be able to confirm this by looking at your chassis/VIN plate, which is under the bonnet, underneath the fiat badge as you look at the front of the car.

find the bit that says motore engine, and it should say 186AXB1A.

failing that do what i did and google the two engine codes, the b1a comes up as a 105jtd, the e1a a 120.

as an aside, have you tried replacing the turbo boost solenoid? might be worth getting one second hand. sorry you may have told us already in the other threads!

if all of the info given on here has been followed then its looking like a wiring or ecu fault. find someone in your yellow pages that tests ecu's/automotive electronics and shop around a bit as prices vary. if your fiat dealer is friendly enough they might tell you who they use.

im not sure i would agree with it being a common fault for the ecu to be faulty, i didnt replace one in ten years on fiat, but thats not to say it isnt. just a hunch mind!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by matt8772; 16-10-2010 at 15:41.
matt8772 is offline Reply With Quote Quote 
Old 16-10-2010   #4
Join Date: Dec 2009
Posts: 233
Thanks: 13
Trader Rating: 0
United Kingdom 
Re: A real head scratcher!! Map Sensor or ECU fault??

Quote Originally Posted by millymoon View Post
Hi, can anyone help?? I recently bought a 2001 1.9TD ELX 105 JTD which required a new turbo. One was duly fitted but the car remained in limp mode with high revs. The fault code P0236 Boost Valve Pressure appeared. My mechanic spoke to Fiat who advised a new MAF sensor, this was duly replaced but the car still remained in limp mode with high revs. The mechanic then followed ALL of the advice given previously on this forum with regards to code clearance but the problem remains. He then transported the car to Fiat for diagnosis and incredibly they said they had no idea what the problem was but it MAY be a faulty ECU, faulty map sensor or faulty turbo.... My ex seems to feel the problem may lie with the MAP sensor. We fitted fiat part no. 46468682 (Bosch 0 281 002 215) which was a direct replacement of the one previously fitted but could possibly have been the wrong part in the first place!! Before I spend any more money on this car I would appreciate some advice on where to go next. It transpires there are TWO Map sensors which fit this car - The one currently fitted and Fiat part no. 46811235 (Bosch 0 281 002 510 or 552) The difference appears to be that one is a 186AXE1A and one is a 186AXB1A can anyone advise what the difference is in part terms. I can find no information about which of these relates to my car. Also would it be beneficial to get the ECU checked? The mileage on the car is only 61,000 and Fiat suggest this is a common fault, if I do need to go down this route I would really appreciate recommendations on reputable companies.
Many thanks in anticipation of help
- My general rule on parts / faults is to put the VIN number in, that way you will get it 99% correct from the get-go.

I have a 2002 110 ELX and a 2000 105 SX, if I look up ePER or AutoData info on date / year / engine type those same details are often very different if you put in the proper Vehicle Identification Number rather than date / type.

Hope this helps
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

QinteQ is offline Reply With Quote Quote 
Old 06-02-2011   #5
Join Date: Jun 2010
Posts: 66
Thanks: 3
Trader Rating: 0
United Kingdom 
Re: A real head scratcher!! Map Sensor or ECU fault??

Guys, thanks very much with your help for this. Sorry for the delay in responding, I had no notification to say someone had posted a reply. Am unbelievably STILL fixing the car and the MAP sensor is still an issue!. I did go ahead and order the part for the 186AXB1A. But recently checking the forums Fiat Parts site I was given the number for the MAP sensor I had previously fitted!!!! My other posting "no vacuum to the turbo actuator" has pretty much documented everything to date. We did however discover yesterday that one of the hoses had been fitted the wrong way up to the overboost valve hence probably why no vacuum! I paid a mechanic to fit all these parts so you would have thought he knew what he was doing I really do appreciate any help that is given. So any more thoughts are very gratefully received
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

millymoon is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) ECU gremlins or real fault? martbass Multipla 4 11-01-2010 10:56
(T) Software update for ECU/throttle body, MAP sensor fault fiatritmo Stilo 13 14-11-2008 14:59
(T) MAP sensor fault Navin Stilo 13 27-05-2008 19:21
(T) MAP sensor fault - but it isn't? [throttle body clean] Steely Stilo 21 01-05-2008 08:22
(S) head scratcher Alex22 Cinquecento / Seicento 10 02-09-2005 21:36