Register Login
endrop - for all your online needs
Reply
 
Thread Tools Search this Thread
Old 04-04-2005   #1
Join Date: Sep 2004
Location: Latvia
Posts: 7
Thanks: 0
Trader Rating: 0
Cuts-out when Idle

Hi,
I have prob with my Marea Weekend 1.6 16V 1998. It had broken thermostat (first) and head gasket (after I think), so that coolant got mixed with oil. That same day the engine cutted out when idle. Head gasket (and many others and thermostat where replaced. Everything seems fine, when accelerator is pressed, but when idle engine simly cuts out (revs fall down to 0) and engine stalls. I've read in forum that it could be dirty idle control valve, but WHERE it is located and width what I should clean it? Maybe you can give me other suggestions with these symptoms. I've tried to reset ECU, but I can't, because after removing battery and reconnecting I can't let the car run idle for five minutes, it just stalls But in the morning one time engine didn't stall when idle (engine was cold)? Please help me with this problem if you can?
__________________
-----------------------------------------------
AI = Fiat Marea Weekend 1.6 SX 16V 1998 =
infest is offline Reply With Quote Quote 
Old 04-04-2005   #2
Join Date: Sep 2004
Location: Latvia
Posts: 7
Thanks: 0
Trader Rating: 0
Re: Cuts-out when Idle

And also when starts, then there is some petrol smell at the beginning!!!
__________________
-----------------------------------------------
AI = Fiat Marea Weekend 1.6 SX 16V 1998 =
infest is offline Reply With Quote Quote 
Old 04-04-2005   #3
Join Date: Nov 2003
Location: Newcastle - upon - Tyne
Posts: 2,587
Thanks: 1
Trader Rating: 0
polecat has donated!
United Kingdom 
Re: Cuts-out when Idle

Hi,
There could be several things causing this problem. The easiest solution would be to get a diagnostic done.

The idle speed actuator is behind the butterfly assembly. You can check that the actuator is working but the butterfly adjusment is a factory job.

Other things to consider:
Temp sensor may be cooked so that the ECU thinks the engine is warm and does not feed extra fuel when cold or the ECU is always feeding extra fuel so that you choke out when idling. Check state of plugs to see if they are wet or black.
Check injectors are clean, try a fuel additive.

Get back if you still have problems.
Good luck.
polecat is offline Reply With Quote Quote 
Old 05-04-2005   #4
Join Date: Sep 2004
Location: Latvia
Posts: 7
Thanks: 0
Trader Rating: 0
Re: Cuts-out when Idle

Thanx. I'll check theese things and also probably will go to the service and try to get a fault code and let you know what was the fault.
__________________
-----------------------------------------------
AI = Fiat Marea Weekend 1.6 SX 16V 1998 =
infest is offline Reply With Quote Quote 
Old 12-07-2005   #5
Join Date: Jun 2005
Location: Tuticorin
Posts: 22
Thanks: 0
Trader Rating: 0
India 
Re: Cuts-out when Idle

I hope that the problem will be with the throttle position sensor. I hope that the position of throttle position sensor will be wrong. In the cold the engine will run in auto choke so you wonít feel this complain....... In heat it will return to the normal RPM on that time if the throttle position sensor doesnít give the right position of the throttle valve means this complain will arise...................

Regards,
Jeyakar.T
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

samy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) 1.1 i.e. timing belt/cambelt and poor mixture (idle fault) andre79ge Uno 7 12-04-2005 16:36
Uno 1.0ie cuts out at idle after a run ColR Lets Talk FIAT 1 23-03-2005 12:38
(T) Uno 1.1. i.e. Erratic Idle andre79ge Uno 5 24-01-2005 09:54
(G) UNO 1.1 i.e. idle problems and iar leacks andre79ge Uno 7 21-11-2004 01:10
(T) [Tipo 1.6 ie 94] Injection light and idle Malex Tipo (Classic) 1 28-07-2004 21:18