Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools Search this Thread
Old 28-08-2004   #1
Join Date: Aug 2004
Posts: 4
Thanks: 0
Trader Rating: 0
Question Marea 20v problems - advice needed

Hi,

I've just bought a Marea Weekend 2.0 HLX, which has a few minor problems that need sorting before I can get on to the fun stuff like the air box mod. Any help on these issues would be much appreciated. Thanks.


The ABS light comes on (and stays on) at speeds above 70mph. I've heard that the rotor part of the ABS sensor is part of the wheel bearing assembly on these cars, if this is true is it possible that the wrong part has been fitted? I guess it could also be due to a faulty sensor, but its odd that it only happens at speed.

The tachometer reads zero at idle and I suspect that its under reading at other engine speeds - I get about 3200rpm at 80mph in 5th gear. What could cause this problem?

How long should it take for the engine to reach normal operating temperature, and what is that temperature? Mine needs 10-15 minutes to reach the 2/5 mark on the gauge which is longer than I'd expect.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

goosander is offline Reply With Quote Quote 
Old 28-08-2004   #2
Join Date: Nov 2003
Location: Newcastle - upon - Tyne
Posts: 2,587
Thanks: 1
Trader Rating: 0
polecat has donated!
United Kingdom 
Re: Marea 20v problems - advice needed

Hi and welcome to the forum.

There is not much you can do with the ABS. Check that the sensors and the toothed rotors are not too dirty or damaged.

The gaps between sensor and rotor should be 0.645-1.305mm on the front and 0.06-1.18mm at the rear.

I get about 3200 rpm in 5th at 70mph. Again I would check the sensor and rotor first.

A bit strange that you are having problems with two separate counter systems, you may be getting electrical noise on the earth somewhere?

The low temp readings seems to be a common feature on the Bravo/a Marea. I was a bit worried at first but i'm pretty sure now that the temp gauge sensor and ECU temp sensor are separate.

Sorry I couldn't be of more help. Let me know how you get on and we'll have another think.
polecat is offline Reply With Quote Quote 
Old 30-08-2004   #3
Join Date: Aug 2004
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Marea 20v problems - advice needed

Hi Polecat,

Thanks for the reply. I've checked and cleaned the front ABS rotors and sensors, but it hasn't made any difference. The rear ones seem to be integrated in to the hub, so I can't really do anything with them.

The front rotors are a bit corroded so perhaps that the problem. I think the next step is to get someone with the right equipment to take a look at it.

I hadn't considered the possibility of a faulty earth but I guess that could explain the problems. I know many older cars have a 10V voltage regulator for the instruments, but don't know if modern cars still have these. If so maybe thats another possibilty.

I've since found another couple of issues:

When the side or head lights are on, a dashboard light indicates that a light bulb has blown but all bulbs are working fine. Also the steering wheel stereo controls don't work.


I need to get hold of a workshop manual for the wiring diagrams, but if that doesn't help I think I'll have to cough up for an auto electrician.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

goosander is offline Reply With Quote Quote 
Old 30-08-2004   #4
Join Date: Nov 2003
Location: Newcastle - upon - Tyne
Posts: 2,587
Thanks: 1
Trader Rating: 0
polecat has donated!
United Kingdom 
Re: Marea 20v problems - advice needed

Don't think there is a 10v reg. Agree that you need electrics looking at.

Good luck with the manual, i've been looking for one for ages. Managed to find a Coupe one for the engine but thats it.
polecat is offline Reply With Quote Quote 
Old 31-08-2004   #5
Join Date: Aug 2004
Location: Bow, London
Posts: 19
Thanks: 0
Trader Rating: 0
Re: Marea 20v problems - advice needed

Dont think this will be of much help but I found and ordered a workshop manual from country books, It covers the Bravo/Brava/Marea & Weekend upto 2001, I haven't received it yet so I cant really comment.

this link should take you to the website:

http://www.countrybookshop.co.uk/boo...for=1899238379

Regards

Peter
__________________
2001 (X) Fiat Morea Weekend 100 SX 1.6 16V
sheldon is offline Reply With Quote Quote 
Old 01-09-2004   #6
Join Date: Aug 2004
Posts: 4
Thanks: 0
Trader Rating: 0
Re: Marea 20v problems - advice needed

Thanks for the link, but I've just bought one off ebay.

The local garage has identified the ABS fault as being a broken reticulator (rotor part of sensor) on one of the front wheels which I missed when I looked at it. Unfortunately the part isn't sold separately so I'll have to replace the CV joint.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

goosander is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Cost of Marea 20v timing belt and tensioner change marea2111 Marea 5 28-04-2006 22:44
Marea Modded Marea 20v Weekend Notorious131 Members Motors 19 17-02-2006 15:56
(T) Marea 20v thermostat, steering pump, cams jbackg Marea 5 29-12-2004 20:20
(T) Just Bought a Marea Weekend, help needed :p shaiboy_uk Marea 4 20-08-2004 23:01
Marea Marea 2.4 20v - IMPROVED I.C.E - New Pics Fernando Members Motors 30 09-12-2003 00:24