Register Login
im Axle Specialists
Reply
 
Thread Tools Search this Thread
Old 3 Weeks Ago   #1
Join Date: Nov 2020
Posts: 1
Thanks: 0
Trader Rating: 0
Turkey 
Poor running for 10 sec. Altitude?

Hey, I am new into the forum. I have a problem of poor running. I have 1.3 multijet(jtd) and when I start the car, it starts well but it has approx. 10 seconds of rough idling. It sometimes stalls. It lights the check engine light for this ten seconds period but no codes are triggered. And the most problematic part f this is it only happens when I come to high altitude place(nearly 2000m or 7000ft). It happens intermittently but nearly all mornings. Sometimes with hot engine. Some say it's because of the software of ecu, some say its because of injectors. I don't think it's because of injectors because there is no black or white smoke and no poor engine power. Can be bad electricity or some?
Thanks in advance.

Procedures done:
Map and maf sensors are cleaned.
Glow plugs and flow plug relay had been changed
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

emrahiz is offline Reply With Quote Quote 
Old 3 Weeks Ago   #2
Join Date: Dec 2019
Posts: 45
Thanks: 9
Trader Rating: 0
damted has donated!
Netherlands 
Re: Poor running for 10 sec. Altitude?

Hi
I have no knowledge for diesel engine, so someone else maybe.
It is also nice if you can also introduce yourself on the forum under the new user section.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

damted is offline Reply With Quote Quote 
Old 3 Weeks Ago   #3
Join Date: May 2020
Posts: 72
Thanks: 8
Trader Rating: 0
Finland 
Re: Poor running for 10 sec. Altitude?

You could try changing the fuel filter then. Also has the car seen service recently? Engine air filter, oil and oil filter need changing too. Check earth, clean battery terminals.

Could it be a vacuum leak from any of the hoses? Also Egr system needs cleaning sometimes.

And edit: ECU did get a software update on the diesel engines but It's presumably done at the dealer check service records.

Also you could check map/ maf sensor readings from obd live data along with some other sensors such as ect (coolant temp). Map or maf may indeed still be faulty. At least the separate one which measures atmospheric pressure outside intake manifold. Have its readings checked at high and low altitude.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by eeeno; 3 Weeks Ago at 10:52. Reason: Added ECU update, map maf sensor diagnostics
eeeno is offline Reply With Quote Quote 
Old 3 Weeks Ago   #4
Join Date: Feb 2016
Posts: 340
Thanks: 17
Trader Rating: 0
United Kingdom 
Re: Poor running for 10 sec. Altitude?

Hi All

If i remember the early 4x4 panda 965cc had a throttle offset adjuster usable from inside the car to assist with the idle when at high altitude, its probably just reduced oxygen just putting things outside normal parameters.

might be worth trying some of the high grade diesel you can get at the pumps, ensure all filters are in good order to maximize airflow.

Tim
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

timmycm850 is offline Reply With Quote Quote 
Old 3 Weeks Ago   #5
Join Date: May 2011
Location: Norfolk UK
Posts: 11,009
Thanks: 528
Blog Entries: 8
Trader Rating: 0
United Kingdom 
Re: Poor running for 10 sec. Altitude?

The running of the engine managed by a number of sensors the main one where altitude is concerned is the mass air sensor which measures the amount of air entering the engine, it should help the engine ECU adjust the appropriate settings to to cope with altitude, itís also a common failure point in the 1.3 multijet
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

AndyRKett is online now Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) poor running marcevs72 Cinquecento / Seicento 13 01-07-2012 14:46
(T) Poor 1.2 Running. Rigby Bravo / Brava 4 04-11-2010 21:26
(T) Poor running mickn Bravo / Brava 9 11-03-2006 23:49
Poor running - please help! smurfhead Lets Talk FIAT 7 30-06-2005 12:26
1.8 poor running PLEASE HELP!! Steve FIAT Boo Archives 12 02-07-2003 22:19